
User’s Guide 

 
 
 
 

TimeStorm® Integrated  
Development Environment 
 
Version 3.2.2 



TimeStorm IDE User’s Guide
Copyright 2003-2007 TimeSys Corporation, 925 Liberty Avenue, Pittsburgh, PA 15222 Unpublished and all rights reserved under
U.S. copyright law and international treaties. TimeSys software documentation is "commercial computer software documentation"
and licensed pursuant to the TimeSys End User License Agreement consistent with FAR 12.212. TimeSys® and the TimeSys logo
are registered trademarks owned by TimeSys Corporation. All TimeSys software product names are trademarks owned by
TimeSys Corporation. All other trademarks are the property of their respective owners.

October 19, 2007



Table of Contents
1. Using TimeStorm IDE .............................................................................................. 1

1.1. About the User’s Guide .................................................................................. 1
1.2. Related Documentation .................................................................................. 1
1.3. TimeStorm Overview ..................................................................................... 2

1.3.1. Capabilities ....................................................................................... 2
1.3.2. Supported Operating Systems ................................................................ 2
1.3.3. Linux Compatibility ............................................................................ 2

1.4. The TimeStorm Development Environment ........................................................ 2
1.5. Online Help ................................................................................................. 3
1.6. Starting TimeStorm ....................................................................................... 4

1.6.1. Starting TimeStorm on Linux or Solaris .................................................. 4
1.6.2. Starting TimeStorm on Windows ........................................................... 4
1.6.3. The Workspace Directory ..................................................................... 4
1.6.4. Startup Options .................................................................................. 5
1.6.5. Using Wizards in TimeStorm ................................................................ 6
1.6.6. Context Menus (Right-Clicking) ............................................................ 6

1.7. Contacting TimeSys ....................................................................................... 6
2. TimeStorm Features ................................................................................................. 7

2.1. The Workbench ............................................................................................ 7
2.1.1. Perspectives ....................................................................................... 8
2.1.2. Navigating Projects, Files, and Workspaces ............................................. 8
2.1.3. Moving Projects ............................................................................... 10

2.2. Editing Source Files in TimeStorm ................................................................. 10
2.2.1. Choosing an Appropriate Perspective ................................................... 10
2.2.2. Opening a Source Code Editor ............................................................ 10
2.2.3. Standard Views ................................................................................ 11

3. Creating Projects ................................................................................................... 13
3.1. The New Project Wizard ............................................................................... 13

3.1.1. C and C++ Project Types ................................................................... 17
3.1.2. Generic versus TimeStorm C and C++ Projects ...................................... 17

3.2. Creating a TimeStorm C or C++ Project .......................................................... 18
3.2.1. Project Name and Location ................................................................. 18
3.2.2. Project Type and Toolchain ................................................................ 19
3.2.3. Project Templates ............................................................................. 21
3.2.4. Files Created by the New Project Wizard ............................................... 22
3.2.5. Importing Files and Projects into TimeStorm ......................................... 24
3.2.6. Creating a New Project from Existing Source Files ................................. 26

3.3. Using TimeStorm with Version Control Systems ............................................... 27
4. Building and Compiling Projects .............................................................................. 28

4.1. About Makefiles, Toolchains, and Build Configurations ..................................... 28
4.1.1. Makefiles ........................................................................................ 28
4.1.2. Toolchains ....................................................................................... 29
4.1.3. Build Configurations ......................................................................... 29

4.2. Installing Toolchains .................................................................................... 29
4.2.1. TimeSys Toolchains .......................................................................... 29
4.2.2. User-Defined Toolchains .................................................................... 30
4.2.3. Adding a User-Defined Toolchain ........................................................ 30
4.2.4. Modifying Toolchains ....................................................................... 35

4.3. Using Build Configurations ........................................................................... 36
4.3.1. The Build Configurations View ........................................................... 37
4.3.2. Creating a New Build Configuration ..................................................... 38
4.3.3. Editing a Build Configuration ............................................................. 39
4.3.4. Setting the Default Build Configuration ................................................ 42

i



4.3.5. Accessing Build Configurations from the Project Properties View .............. 42
4.3.6. Related Project Settings ..................................................................... 44

4.4. Overriding Build Configuration Settings for a File ............................................. 45
4.5. Project Properties Settings ............................................................................ 46

4.5.1. Build Products ................................................................................. 47
4.6. Makefile Customization ................................................................................ 48

4.6.1. Using Supplemental Makefiles ............................................................ 48
4.7. Compiling C and C++ Applications ................................................................ 48

4.7.1. Automatic Builds .............................................................................. 50
4.7.2. Manual Builds .................................................................................. 51

5. Downloading and Running Applications from TimeStorm ............................................. 52
5.1. C and C++ Launch Configurations ................................................................. 52
5.2. Accessing Launch Configurations .................................................................. 52

5.2.1. Run and Debug Modes ....................................................................... 52
5.2.2. The Configurations List ..................................................................... 53

5.3. Creating Launch Configurations ..................................................................... 54
5.3.1. About the C/C++ Remote Launch Configuration ..................................... 54
5.3.2. Main Panel Options ........................................................................... 55
5.3.3. Arguments Panel Options ................................................................... 57
5.3.4. Environment Panel Options ................................................................ 58
5.3.5. Debugger Panel Options ..................................................................... 58
5.3.6. Source Panel Options ........................................................................ 61
5.3.7. Target Panel Options ......................................................................... 62
5.3.8. Download Files Panel Options ............................................................. 63
5.3.9. Common Panel Options ..................................................................... 63

5.4. Running an Application from TimeStorm ........................................................ 65
5.5. Console View ............................................................................................. 67
5.6. Debugging ................................................................................................. 69

5.6.1. Prerequisites for Debugging ................................................................ 69
5.6.2. The Debug Perspective ...................................................................... 70
5.6.3. Starting a Debugging Session .............................................................. 71
5.6.4. Debugging Shared Libraries ................................................................ 72

6. Tutorial: Creating a TimeStorm Project ...................................................................... 78
6.1. Overview ................................................................................................... 78
6.2. Using the New Project Wizard ....................................................................... 78

6.2.1. Start the New Project Wizard .............................................................. 78
6.2.2. Choose a Project Category and Type .................................................... 79
6.2.3. Name the Project .............................................................................. 80
6.2.4. Specify the Project’s Type and Toolchain .............................................. 80
6.2.5. Specify a Project Template ................................................................. 81
6.2.6. Files Created .................................................................................... 82
6.2.7. Build the Project ............................................................................... 83
6.2.8. Files Shown after the Build ................................................................. 84

6.3. Editing Source Files ..................................................................................... 85
6.3.1. Open a Source Code Editor ................................................................. 85
6.3.2. Modify the Source File ...................................................................... 86

6.4. Building and Compiling ............................................................................... 87
6.4.1. Open the Build Configurations View .................................................... 87
6.4.2. Create a Custom Build Configuration ................................................... 88
6.4.3. Modify the New Build Configuration’s Settings ...................................... 91
6.4.4. Save the Build Configuration .............................................................. 94
6.4.5. Compile the Application .................................................................... 94

6.5. Downloading and Running the Application ...................................................... 96
6.5.1. Open the Launch Configurations Panel ................................................. 96
6.5.2. Create a New C Remote Launch Configuration ....................................... 97
6.5.3. Specify the Application To Run ........................................................... 98
6.5.4. Configure Target Communication ........................................................ 98
6.5.5. Test the Download Setup .................................................................... 99

TimeStorm IDE User’s Guide

ii



6.5.6. Save the Configuration ...................................................................... 99
6.5.7. Run the Application ........................................................................ 100

Index .................................................................................................................... 101

TimeStorm IDE User’s Guide

iii



Chapter 1 - Using TimeStorm IDE
This chapter introduces TimeStorm IDE and the TimeSys host-target development environment, de-
scribes how to start the software, and gives information about this document and other available
TimeStorm documentation.

1.1 About the User’s Guide
This guide gives details about the features of the TimeStorm Integrated Development Environment
(IDE) and how to use them. Chapter 6, Tutorial: Creating a TimeStorm Project, describes procedures
for creating a basic C application, building it, and transferring and running it on a Linux target system.

A separate document provides details about using the Target Configurator plug-in, which allows you to
build Linux kernels and root file systems. Refer to Section 1.2, Related Documentation, for details. Doc-
umentation also is available separately for the Linux Verification Suite plug-in, which provides a graph-
ical environment for testing Linux distributions, and for the Linux Profiling Suite plug-in, which allows
you to profile and analyze your Linux code so that you can troubleshoot any performance issues.

If you have not yet installed TimeStorm, or if you have not yet set up your host and target systems, refer
to Getting Started with TimeStorm for instructions about how to install and configure your TimeStorm
development environment.

1.2 Related Documentation
TimeStorm includes the following additional documentation. All documents, except for online help, are
available from the /doc directory of the downloaded archive and in the /doc directory installed with
your software. On Windows systems, a link to documentation also appears in the Start menu.

• Getting Started with TimeStorm – This guide contains software requirements and installation and
setup instructions for creating a TimeStorm development environment. The document’s filename is
getting_started.pdf.

• TimeStorm Release Notes – The release_notes_ts.txt file contains late-breaking product informa-
tion and describes workarounds for any existing problems.

• TimeStorm Online Documentation – The TimeStorm Online Documentation gives detailed informa-
tion about TimeStorm capabilities and procedures. To access online help, start TimeStorm and select
Help > Help Contents.

• Target Configurator documentation – A separate user’s guide, release notes file, and online help are
provided for Target Configurator. The TimeStorm Target Configurator User’s Guide is delivered as
user_guide_tc.pdf, the release notes file is delivered as release_notes_tc.txt, and the
TimeStorm Target Configurator Online Documentation is also available. Target Configurator docu-
mentation appears only on systems with the Target Configurator plug-in installed.

• Linux Verification Suite documentation – If you installed the TimeStorm Linux Verification Suite
(LVS), a separate user’s guide, release notes file, and online help for LVS are provided. The
TimeStorm Linux Verification Suite User’s Guide is delivered as user_guide_lvs.pdf, the release
notes file is delivered as release_notes_lvs.txt, and the TimeStorm LVS Online Documentation is
also available. LVS documentation appears only on systems with the LVS plug-in installed.

• Linux Profiling Suite documentation – If you installed the TimeStorm Linux Profiling Suite (LPS), a
separate user’s guide, release notes file, and online help for LPS are provided. The TimeStorm Linux
Profiling Suite User’s Guide is delivered as user_guide_lps.pdf, the release notes file is delivered
as release_notes_lps.txt, and the TimeStorm LPS Online Documentation is also available. LPS
documentation appears only on systems with the LPS plug-in installed.
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1.3 TimeStorm Overview
TimeStorm IDE 3.2.2 is a graphical integrated development environment (IDE) that is customized for
use with Linux operating systems that run on remote targets.

1.3.1 Capabilities
TimeStorm supports development of embedded applications in C or C++, as well as general-purpose ap-
plication development in C, C++, or Java. It also supports development of static or shared libraries.

In addition to providing a code development editor and build tools, TimeStorm smoothly integrates
Linux development toolchains that allow you to cross-compile your code for your target systems.
TimeStorm includes graphical utilities that allow you to run and debug your code on a remote system.

TimeStorm’s Target Configurator plug-in allows you to create Linux kernels, kernel modules, and root
file systems for a target system. With Target Configurator, you can build a complete system configura-
tion for your target board.

TimeStorm’s Linux Verification Suite (LVS) plug-in provides a graphical testing interface that can be
used to validate a modified Linux kernel, root file system, and other components of a Linux distribution.

TimeStorm’s Linux Profiling Suite (LPS) plug-in profiles all aspects of your Linux code, including
hardware and software interrupt handlers, kernel modules, the kernel, shared libraries, and applications.
LPS then enables you to view both a statistical analysis and a graphical analysis of the profiled code and
to view the annotated source code so that you can pinpoint any performance issues quickly and easily.

1.3.2 Supported Operating Systems
TimeStorm runs on a desktop workstation that uses a Linux, Solaris, or Windows operating system. Spe-
cific hardware and software requirements are included in the separate document Getting Started with
TimeStorm.

Note:
Target Configurator, LVS, and LPS are not supported on Solaris systems.

1.3.3 Linux Compatibility
TimeStorm can be used to develop, run, and debug applications on most Linux distributions, including
embedded and general-purpose systems.

TimeSys provides embedded Linux distributions for a wide range of target architectures, which are de-
signed for compatibility with TimeStorm. When using TimeStorm with one of these distributions, some
configuration steps are automated, and toolchain compatibility is guaranteed.

When using Linux distributions not provided by TimeSys, additional configuration steps are required
when installing toolchains. Extra configuration may be required for other tasks as well, depending on the
completeness of the toolchain delivered with your Linux software development kit, and on its installa-
tion procedures.

1.4 The TimeStorm Development Environment
A TimeStorm IDE development environment includes several components in addition to the TimeStorm
software. The setup comprises the following:

• A TimeStorm host system – The TimeStorm host is the desktop computer that runs TimeStorm IDE
software. The TimeStorm host must have appropriate software for creating the type of applications
you want to develop. (Software requirements are addressed in detail in Getting Started with
TimeStorm.)

Using TimeStorm IDE
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• A target system – The target executes the applications or kernel modifications that you develop us-
ing TimeStorm. The target might run a Linux distribution from TimeSys, or might use another Linux
operating system. A target can be a development board used for prototyping, a full-fledged PC, or
something in between.

• An RFS host system (optional) – In most cases, the target accesses its root filesystem and other ser-
vices remotely instead of hosting them locally. The RFS host provides infrastructure to the target, in-
cluding the root filesystem. Optionally, the TimeStorm host can also serve as the RFS host.

• A network connection – The TimeStorm host, the target, and the RFS host must be able to commu-
nicate by using an Ethernet connection. Serial connections may be substituted for some activities –
for example, debugging a kernel on a remote target requires a serial connection. (Work with kernels
also requires the Target Configurator plug-in.)

Information about setting up the target system and RFS host should be provided in the documentation
provided with your target’s Linux distribution. For Linux distributions from TimeSys, read the Getting
Started guide provided with your distribution. Information about setting up and configuring the
TimeStorm system is provided in Getting Started with TimeStorm, which was delivered with this soft-
ware as getting_started.pdf.

TimeStorm’s user interface is called the workbench. TimeStorm uses the Eclipse open source develop-
ment environment as a basis for implementing its customized functionality, and some tools in the work-
bench are generic tools provided as part of Eclipse. TimeStorm also includes workbench tools that are
specifically customized for use with a remote Linux system.

Chapter 2, TimeStorm Features, gives more detailed information about the TimeStorm workbench.

1.5 Online Help
Online help is provided with TimeStorm in the form of HTML files rendered in a browser by the work-
bench. To access help in TimeStorm, select Help > Help Contents from the main menu in TimeStorm.

The online help includes several help sets. The TimeStorm Online Documentation describes interfaces
and tasks that are specific to TimeStorm.

Depending on the TimeStorm software you have installed, you might see the following help sets in the
Help Contents page:

• Workbench User Guide – Describes basic interfaces and tasks in the Eclipse workbench.

• Java Development User Guide – Describes Java development tasks and interfaces.

• TimeStorm Online Documentation – Gives details about TimeStorm-specific tools and concepts.

• Linux Manpages – Contains HTML versions of the generic Linux man pages that are supplied with
this Linux distribution from TimeSys.

• TimeSys Manpages – Contains HTML versions of the TimeSys-specific Linux man pages that are
supplied with this Linux distribution from TimeSys.

• C/C++ Development User Guide – Documents features of the C Development Toolkit (CDT),
which provides the basis of TimeStorm’s C development functionality.

• TimeStorm Target Configurator Online Documentation – Supplies details about features and tasks in
the Target Configurator plug-in.

• TimeStorm LVS Online Documentation – Gives details about features and tasks in the LVS plug-in.

• TimeStorm LPS Online Documentation – Gives details about features and tasks in the LPS plug-in.

Using TimeStorm IDE
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1.6 Starting TimeStorm
This section explains how to start TimeStorm IDE and describes startup options.

1.6.1 Starting TimeStorm on Linux or Solaris
On a Linux or Solaris system, start TimeStorm by executing the timestorm.sh command. For example,
use the following:

$ /opt/timesys/timestorm/3.2/timestorm.sh

It is not necessary to run TimeStorm as the local super user, root; however, if you use Target Configurat-
or on a Linux system to create kernels or root file systems, you must configure the super user do utility,
sudo, to provide root-equivalent access for some tasks. The TimeStorm Target Configurator User’s
Guide includes details about Sudo configuration.

1.6.2 Starting TimeStorm on Windows
On a Windows system, start TimeStorm by using the Start menu to choose Programs > TimeStorm
Tools 3.2 > TimeStorm.

Alternatively, you can start TimeStorm from a command line by opening the Windows Command
Prompt or the Cygwin Bash shell, changing to the directory C:\Program

Files\TimeSys\TimeStorm\3.2 and executing timestorm.exe (for example, by using the command
./timestorm.exe).

(If you do not have a Cygwin shortcut on your Windows desktop or Start menu, you can open a Cygwin
Bash shell by locating the cygwin.bat file and double-clicking it. By default, this file is located in
C:\Cygwin.)

1.6.3 The Workspace Directory
TimeStorm creates a workspace directory that it uses for storing project files and state information about
TimeStorm. The directory is named TimeStorm-workspace by default.

When you start TimeStorm, you are asked to specify the directory’s location, as shown in Figure 1.1.

Figure 1.1. Choosing a workspace

Using TimeStorm IDE
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The default workspace location for Linux systems is in the user’s home directory, for example,
/home/juser/workspaces/TimeStorm-workspace. On Windows systems, the default value is
C:\workspaces\TimeStorm-workspace. However, TimeStorm also attempts to locate any existing work-
space directories from previous installations and suggests an existing directory as the default value if
one exists.

You also can specify a different workspace directory at the command line by using the -data option as
described in Section 1.6.4, Startup Options.

1.6.4 Startup Options
TimeStorm offers some additional command-line options for customizing how TimeStorm runs.
TimeStorm’s default configuration is appropriate in most cases.

Table 1.1. TimeStorm startup options

Option Effect

-consolelog Mirrors the workbench’s error log to the console used to run TimeStorm.

-data workspace_path Specifies the directory where project files are stored.

-debug options_file_path Starts TimeStorm in debug mode using the options specified in the file. If
no file location is supplied, TimeStorm looks for a file called .options in
the directory from which TimeStorm was started.

-nl locale Defines the name of the locale on which TimeStorm is running. This set-
ting is normally computed automatically; using this option overrides that
result.

-vm vm_path Specifies the location of the Java Runtime Environment used to support
TimeStorm. If no location is specified, TimeStorm uses the JRE provided
by the installer as described in Chapter 3 of Getting Started with
TimeStorm. TimeStorm requires Java support software of version 1.5 or
later.

Using TimeStorm IDE
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Relative paths are allowed as values and are interpreted as relative to the directory from which
TimeStorm was started.

To use command-line options on Windows systems, you must start TimeStorm from a command line in-
stead of using a shortcut. Use the Cygwin Bash shell, a Windows Command Prompt window, or the
Run menu to issue the timestorm.exe command with the arguments described above.

Additional information about these commands is included in the Workbench User Guide online help. In
the Tasks section, click on the topic named Running Eclipse.

1.6.5 Using Wizards in TimeStorm
TimeStorm uses step-through wizards to guide you through many of its processes, including creating
projects. These wizards are intuitive after you have used them a few times. Each wizard step allows you
to enter information.

• To enter information in a text field, place the cursor in the box and type.

• The Next button is activated after all of the necessary information is entered into the screen. All of
the screens except the last one have a Next button.

• The Back button allows you to return to previous screens to change information. In general, the in-
formation you have entered is retained when you start going forward again. All of the screens except
the first one have a Back button.

• The Finish button is activated after all of the necessary information is entered into all of the screens.
This button allows you to complete the process.

• The Cancel button allows you to exit the process. No information is retained in this case.

• The Browse button lets you search for a file, rather than typing the complete path name in a field.

1.6.6 Context Menus (Right-Clicking)
TimeStorm uses context menus, which let you quickly access the most useful commands and properties
related to the object or window with which you are working. Context menus list only those commands
that pertain to the item under the cursor. To use a context menu:

1. Position the cursor over an item in the workbench.
2. Click the right mouse button (right-click) to display the context menu.
3. Choose the command from the context menu and release the mouse button.

1.7 Contacting TimeSys
TimeSys has made every effort to ensure that this document is accurate and error-free. If you find an
error or have suggestions that would improve it, please let us know by sending e-mail to
documentation@timesys.com.

If you have questions about or problems with the TimeSys platform, or if you think you have discovered
an error in the software, log onto the LinuxLink Help page at:

https://linuxlink.timesys.com/

If you need further assistance, call for technical support at 1-888-432-8463.

Sales information can be obtained by sending e-mail to sales@timesys.com or by calling
412-232-3250. Additional contact information is available on the TimeSys web site at:

http://www.timesys.com/

Using TimeStorm IDE
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Chapter 2 - TimeStorm Features
The next few chapters describe features of the TimeStorm IDE graphical user interface, which is called
the workbench. Features that are specific to TimeStorm are explained in detail. Workbench features that
are part of the standard Eclipse development environment, which serves as the basis for TimeStorm
IDE, are documented more completely in the online Workbench User Guide, which is available from the
TimeStorm Help menu.

2.1 The Workbench
The TimeStorm workbench is shown in Figure 2.1.

Figure 2.1. The TimeStorm workbench (C/C++ perspective)

The central panel of the workbench contains editors. Use the tabs at the tops of the editing windows to
switch from one open editor to another. TimeStorm includes a wide variety of editors, including editors
customized for source code development.

The other panels are known as views. Views display information about your projects and workspace.
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2.1.1 Perspectives
You can rearrange the views and editors in your workbench as you wish. Saved arrangements of views
and editors are called perspectives. By default, TimeStorm saves your current perspective settings when
you exit TimeStorm and reestablishes it when you start again.

If you want the workbench to revert to the standard layout for the current perspective, use the Window
> Reset Perspective command.

TimeStorm includes preset perspectives that contain tools for particular tasks. For example, the C/C++
perspective has views and menu items that are customized for modifying C or C++ code and building
executables. The Debug perspective shows debugging tools and related views.

When TimeStorm initially opens, it loads the C/C++ perspective by default. If you create a new project
of a different type, TimeStorm switches to the appropriate perspective automatically. For example, if
you create a new Java project, TimeStorm switches to the Java perspective. For development tasks in
TimeStorm, using the C/C++ or Java perspective is typically more convenient than using the Resource
perspective. Resource is the generic name for a file, project, or directory in the workbench.

2.1.2 Navigating Projects, Files, and Workspaces
Projects are collections of related files that can be managed as a unit. You can work with multiple
projects at the same time.

Files in TimeStorm are always associated with projects. Any file that you want to work with in
TimeStorm must be part of a project. Typically, files that are part of a project are stored in the project’s
directory; you can copy files from another location to add to a project by using the Import wizard, or you
can use linked resources to reference files outside a project’s directory. The Import wizard is described
in Section 3.2.5, Importing Files and Projects into TimeStorm. Linked resources are documented in the
Workbench User Guide online help.

Each project has its own directory. Project files can be organized in subdirectories within the project dir-
ectory.

TimeStorm projects are associated with workspaces. The term workspace can be used to mean a physic-
al storage location, but in TimeStorm it should also be thought of as a virtual set of files that is associ-
ated with a particular instance of TimeStorm. All projects and files that are available in TimeStorm are
part of that workspace; in order to work with a file, you must create it in a workspace, import it into the
workspace, or link to it from the workspace. When you start TimeStorm, you instantiate one specific
workspace.

A particular storage location is associated with a workspace. You can specify a directory to serve as the
storage location, as described in Section 1.6.3, The Workspace Directory. The default value is a direct-
ory named workspaces/TimeStorm-workspace that is created the first time that TimeStorm starts. The
default workspace is stored in the user’s home directory on Linux systems, or in the root level of the de-
fault hard drive on Windows. Here are some examples:

On Linux: /home/juser/workspaces/TimeStorm-workspace

On Windows: C:\workspaces\TimeStorm-workspace

If you create a new project using default settings, a new directory is created for the project within the
workspace storage location.

Note:
It is possible to store projects and other files outside of the TimeStorm-workspace directory. It
is not necessary to install toolchains or kernel source files within the workspace location, and
you can specify a non-default directory when creating a project. You also can import projects
that are stored in a version control system without having to move the files to the workspace
storage location.

TimeStorm Features
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Several hierarchy-based views can be used to navigate files and projects. Although these views look
similar, and appear together in the left column of their perspectives by default, they are different:

• The Navigator view shows all project directories and files that are part of your current workspace
file system.

• The C/C++ Projects view, which appears in the left column of the C/C++ perspective, shows the
structure of C and C++ projects in the current workspace.

• The Package Explorer view, which appears in the left column of the Java perspective, shows the
structure of open Java projects in the current workspace.

Both the C/C++ Projects view and the Package Explorer view show structural elements that are con-
tained within files. The default Java perspective also includes an object hierarchy view. If you have no
open projects, the C/C++ Projects, Package Explorer, and Java object Hierarchy views are not
shown, or appear empty.

Projects and files that are not part of the workspace for the current TimeStorm session do not appear in
the Navigator. They can be added to the current workspace by using the Import wizard, which is de-
scribed in Section 3.2.5, Importing Files and Projects into TimeStorm.

Figure 2.2 gives a side-by-side presentation of the C/C++ Projects view and the Navigator view for the
same workspace so that you can see the differences.

Figure 2.2. Differences between hierarchy views

Most actions related to files and projects are invoked by right-clicking the objects in one of these views.
For example, to close a project, right-click on the project folder in the C/C++ Projects or Navigator
view and select Close Project from the context menu. (On Linux hosts, first select the project folder and
then right-click to display the menu.) Some actions are only possible from one view or the other.

TimeStorm Features
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2.1.3 Moving Projects
TimeStorm projects can be moved from one directory to another by right-clicking on the project name in
the C/C++ Projects or Navigator view and selecting the Move option. Other methods, such as operat-
ing system move, copy, or delete commands, are not recommended for files that are referenced by a
TimeStorm workspace.

2.2 Editing Source Files in TimeStorm
TimeStorm edits files by starting the default editor for that type of file within the workbench. Refer to
the Workbench User Guide online help for information about specifying default editors.

2.2.1 Choosing an Appropriate Perspective
The top right toolbar includes a button for opening perspectives, as shown in Figure 2.3.

Figure 2.3. Open Perspective button

When multiple perspectives have been opened in the workbench, the toolbar containing the Open
Perspective button has additional buttons representing the recently used perspectives. You can switch
between perspectives for the current project by clicking on those buttons.

Typically, you will use the C/C++ perspective or the Java perspective to edit source files, and the
Debug perspective to perform debugging. Switch perspectives by using the buttons described above, or
by using the Window menu to choose Open Perspective > perspective name. If the perspective that
you want to open does not appear on the recently used perspectives menu, choose Open Perspective >
Other to show all available perspectives.

2.2.2 Opening a Source Code Editor
Double-clicking on an editable file in the C/C++ Projects, Package Explorer, or Navigator view
opens the file in its associated editor. For example, double-clicking on a .c file opens the C/C++ source
code editor, as shown in Figure 2.4.

TimeStorm Features
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Figure 2.4. A “C” file open for editing (C/C++ perspective)

2.2.3 Standard Views
With a project open, you can explore the different views available in TimeStorm. More complete in-
formation about these views is provided in the Workbench User Guide or in the TimeStorm Online Doc-
umentation online help.

• C/C++ Projects – A hierarchy of C and C++ projects in this instance of TimeStorm. (Refer to
Section 2.1.2, Navigating Projects, Files, and Workspaces, for more information about the C/C++
Projects and Navigator views.)

Note:
The Java perspective shows the Package Explorer and Hierarchy views instead of the C/C++
Projects view.

• Navigator – A hierarchy of the project files known to this instance of TimeStorm. (Refer to
Section 2.1.2, Navigating Projects, Files, and Workspaces for more information about the C/C++
Projects and Navigator views.)
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• Problems – A list of build errors and warnings from recent actions.

• Console – A utility for establishing a Telnet, SSH, or serial connection to another system. Also, dis-
plays the messages output during a build process.

• Properties – A display of the properties of whatever item is currently selected.

• Build Configurations – A list of existing build configurations for your project. Build configurations
are described in Chapter 4, Building and Compiling Projects. This view only applies to TimeStorm
C and C++ projects.

• Outline – A graphical diagram that shows the structure of an item that is being edited.

• Make Targets – Shortcuts for building your application with various Make options. Additional in-
formation is available in Chapter 4, Building and Compiling Projects.

TimeStorm Features
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Chapter 3 - Creating Projects
Creating a TimeStorm project is simple – just follow the steps in the New Project wizard. This chapter
details the procedure for creating different types of C and C++ projects in TimeStorm. It also describes
how to import files to populate your project, and gives hints for using version control systems in
TimeStorm IDE.

Chapter 6, Tutorial: Creating a TimeStorm Project, walks you through using the wizard to create a
TimeStorm C application project.

3.1 The New Project Wizard
The New Project wizard helps you to create a project. You must create a new project for your develop-
ment work, unless you can import an existing TimeStorm project from another TimeStorm workspace or
from a version control system.

Before starting the New Project wizard, make sure that the toolchain you want to use is installed on your
TimeStorm system.

There are several ways to start the New Project wizard. You can use any one of the following methods:

• Click the New button in the toolbar.

• Use the File menu to choose New > Project.

• Use the New button’s drop-down menu to select New > Project. Figure 3.1 shows the New button’s
menu.
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Figure 3.1. The New Project menu

TimeStorm starts the New Project wizard, as shown in Figure 3.2.
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Figure 3.2. The New wizard

This wizard is used for creating new files, directories (folders), and many different types of projects, as
well as for checking out files from a source control system.

If you have installed Target Configurator or LVS, additional options appear in this list for System Con-
figuration, TimeStorm Kernel Project, and LVS. Refer to the TimeStorm Target Configurator User’s
Guide and TimeStorm Linux Verification Suite User’s Guide for information about these options.

TimeStorm provides specialized project types for C and C++ projects. Expanding the category shows
the TimeStorm-specific project types, as shown in Figure 3.3.

Creating Projects
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Figure 3.3. Specialized project types
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After selecting the type of project that you want to create, click Next. (The Next button is only active if
a project type is selected.)

3.1.1 C and C++ Project Types
TimeStorm IDE includes special features for creating cross-compiled applications, shared libraries, or
static libraries in C or C++. Before choosing which kind of project to create, you must specify whether
to use C or C++.

Note:
Target Configurator adds the capability to create root file systems, Linux kernels, and loadable
kernel modules. These options do not appear as C projects, but instead are listed separately un-
der the categories System Configuration and TimeStorm Kernel Project. These category
headings are visible in Figure 3.3.

Additional information about these options is included in the TimeStorm Target Configurator
User’s Guide and in the TimeStorm Target Configurator Online Documentation.

TimeStorm displays the following options for C and C++ projects:

• Convert to a C/C++ Make Project – Instead of creating a project, this option allows you to change
one or more existing projects from C to C++ or vice versa. The project to change is specified later in
the wizard. Details about this task are included in the C/C++ Development User Guide online help.

• Managed Make C Project or Managed Make C++ Project – This option creates a generic C or
C++ project with a TimeStorm-managed makefile. These projects do not use cross-compiler tool-
chains. Other differences between these projects and TimeStorm C and C++ projects are described in
Section 3.1.2, Generic versus TimeStorm C and C++ Projects.

• Standard Make C Project or Standard Make C++ Project – This option creates a generic C or
C++ project without a makefile. You must create and maintain your own makefile. Generic projects
do not use cross-compiler toolchains. Other differences are described in Section 3.1.2, Generic
versus TimeStorm C and C++ Projects.

• TimeStorm C Project or TimeStorm C++ Project – This option creates a customized C or C++
project that includes a cross-compiling step. Later in the New Project wizard you can choose the
type of output to create (application, static library, or shared library) and which toolchain to use.
Other differences between a TimeStorm project and a generic project are described in Section 3.1.2,
Generic versus TimeStorm C and C++ Projects.

The C++ wizard also shows the option Class, which creates a new C++ class (you must specify an exist-
ing C++ project as part of the class creation process).

For remote, cross-platform development, choose either TimeStorm C Project or TimeStorm C++
Project.

3.1.2 Generic versus TimeStorm C and C++ Projects
The New Project wizard can create generic or TimeStorm projects in C and C++. TimeStorm projects
are customized to enable remote execution and to automate certain tasks related to embedded application
development.

A TimeStorm C or C++ project has the following important differences from a generic C or C++
project:

• TimeStorm projects allow you to select a cross-compiler from the list of installed toolchains. Gener-
ic projects use the default GNU compiler.

Creating Projects
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• TimeStorm C and C++ projects can provide a rudimentary source code file that you can build as
soon as the project is created. This option is not provided for generic projects.

• The Profile build configuration is present in TimeStorm C and C++ projects, but is not present in
generic C and C++ projects.

• TimeStorm projects can be cross-compiled automatically using a toolchain from a Linux distribution
provided by TimeSys. Build configurations for TimeStorm projects include the ability to select a
toolchain. Generic projects cannot automatically use toolchain cross-compilers to create output for a
target platform.

3.2 Creating a TimeStorm C or C++ Project
When you create a TimeStorm C or C++ project using the New Project wizard, you specify the options
described in this section. These panels appear after you select either TimeStorm C Project or
TimeStorm C++ Project and click Next.

3.2.1 Project Name and Location
First, you must set the name and storage location of the project, as shown in Figure 3.4. The default loc-
ation is your workspace.

Figure 3.4. Project name and location panel
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If you accept the default storage location in the Project contents section, a directory with the name of
your project is created in the TimeStorm-workspace directory to hold your project files. However, if you
specify a custom location, you must specify the complete path, including the directory that will hold the
project files. TimeStorm creates directories specified in this field if they do not already exist.

When locating projects in custom directories, keep in mind that each project must have a unique path,
and that a project cannot be stored in a subdirectory of another project’s directory. That is, if you store a
project in /home/juser/projectA you cannot create another project with the path
/home/juser/projectA/projectB.

3.2.2 Project Type and Toolchain
In the next panel of the New Project wizard, you must specify the project’s output type and the toolchain
to use when building the project. You also can specify whether or not to create a rudimentary source
code file for the project.

TimeStorm C and C++ projects can provide any of three types of output:

• Application (executable)
• Shared library
• Static library

Select the type of project that you want to create from the drop-down menu labeled Project Type, as
shown in Figure 3.5.

Figure 3.5. Project Type and Toolchain panel

You also can select the toolchain that TimeStorm uses to build your project by using the Toolchain
drop-down menu, as shown in Figure 3.6.
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Before starting the New Project wizard, make sure the toolchain that you want to use is installed on your
host system. If the toolchain is not from a Linux distribution provided by TimeSys (version 4.0 or later),
you also must define the toolchain by using the Add Toolchain wizard described in Section 4.2.2, User-
Defined Toolchains. When creating the new project, you must select a toolchain to associate with the
project so that the wizard can create the project’s initial build configurations.

Figure 3.6. Selecting a toolchain

The native toolchain that appears in the list is provided by your TimeStorm host system’s development
environment and does not include a cross-compiler. Use the native toolchain if you want to compile
your application to run locally on the TimeStorm host machine.

Later, you can change to a different toolchain by modifying the project’s build configurations as de-
scribed in Chapter 4, Building and Compiling Projects.

You can also choose whether or not to use a basic source code template. Clear or select the checkbox
labeled Create a project with an initial source code template to alter this setting.

After you specify a project type and toolchain, the Finish button is active. If you did not select the
checkbox, click Finish to create the project. If you did select the checkbox, a final panel appears, as de-
scribed in the next section.
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3.2.3 Project Templates
In the Templates panel, shown in Figure 3.7, you can choose a template for either a hello embedded c
application project or for a simple c multi-threaded application project.

Figure 3.7. Selecting a template

After you select a template, click Finish to create the project.
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3.2.4 Files Created by the New Project Wizard
TimeStorm uses the name and path that you gave to create project files and a project storage directory.
The completed project appears in the C/C++ Projects view.

TimeStorm creates the following items as part of the project:

• A directory to contain the project files

If you specified a custom path, TimeStorm shows a virtual directory with the project name, even if
no actual directory with that name exists.

• Build configurations for the project

Build configurations appear in the Build Configurations view. TimeStorm creates one of each of
the three types of build configurations – Debug, Profile, and Release – and sets the debug build con-
figuration as the default setting.

• A rudimentary source code file for the project (optional)

TimeStorm only creates a source code file if you chose to create one in the New Project wizard. This
is an option in the Project Type and Toolchain panel (shown in Figure 3.5). Different files are cre-
ated depending on the type of project (C or C++, executable, or library). The file is created with the
optional template you chose in the Templates panel (shown in Figure 3.7).

Figure 3.8 shows the workbench with a new C application project. This project includes a TimeStorm-cre-
ated initial source code file, which is open in the code editor. You also can see customized build config-
urations for the new project listed in the Build Configurations view.

Figure 3.8. Files from the new project
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If automatic builds are enabled for your workspace, TimeStorm builds the project immediately after cre-
ating it. (Chapter 4, Building and Compiling Projects, includes details about building projects automatic-
ally and manually.)

Figure 3.9 shows the project files before a build. No makefile exists because TimeStorm 3.2.2 only cre-
ates a makefile when a build is requested. Before the first build, only the source code file – which has
the same base name as the project – exists.

Figure 3.9. The new project before a build

Figure 3.10 shows the same project after a build. (Details about building a project are included in
Chapter 4, Building and Compiling Projects.) TimeStorm automatically generates a makefile and builds
the project using the currently active build configuration (in this case, the Debug configuration).
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Figure 3.10. The new project files after a build

Additional project files are created that are not directly edited by the TimeStorm user. Several files be-
ginning with a period (.) are created to hold state information about the project, and a file named with
the project name and the extension .o is created as an intermediate file during the project’s build. Out-
side of the project directory, a directory in the workspace named .metadata contains workspace state in-
formation. These files should be ignored.

3.2.5 Importing Files and Projects into TimeStorm
The Import wizard adds files to a TimeStorm project, or adds a project from another workspace
(including from a version control system) to your workbench.

The Import wizard cannot be used to add toolchains to the TimeStorm environment. Use the Add Tool-
chain wizard as described in Section 4.2.2, User-Defined Toolchains.

If you are converting a project that was not created in TimeStorm IDE or in Eclipse 2.0 or later, you
must create a TimeStorm project and then import the project files. Open the Import wizard by choosing
File > Import or by right-clicking on the project name in the Navigator view and selecting Import.
The Import wizard is shown in Figure 3.11.
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Figure 3.11. Import wizard

The Import wizard gives the following options:

• Archive file – Choose this option to import files from a .zip or .jar format archive file into an ex-
isting TimeStorm project. Refer to the Workbench User Guide online help for additional information
about this option.

• Checkout Projects from CVS – Use this option to add a project from a CVS source control system
repository to your TimeStorm workspace. Additional information about this option is included in the
Workbench User Guide online help.
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• Existing Projects into Workspace – Choose this option to add an existing TimeStorm or Eclipse
project to your current workspace.

• External Features; External Plug-ins and Fragments – These options allow you to customize
your TimeStorm environment by adding Eclipse features and plug-ins. Refer to the Workbench User
Guide online help set for additional information about these options.

• File system – Choose this option to import files into an existing TimeStorm project. Additional in-
formation about this option is included in Section 3.2.6, Creating a New Project from Existing
Source Files, and in the Workbench User Guide online help.

• Preferences – Choose this option to import preferences from the local filesystem. Additional in-
formation about this option is included in the Workbench User Guide online help.

• Team Project Set – Choose this option to import version control information for a shared set of
projects. The Workbench User Guide online help includes additional information about this option.

If you have installed Target Configurator, LVS, or LPS, additional options also appear in this list. Con-
sult the TimeStorm Target Configurator User’s Guide, the TimeStorm Linux Verification Suite User’s
Guide, and TimeStorm Linux Profiling Suite User’s Guide, respectively, to learn more about using the
custom options.

3.2.6 Creating a New Project from Existing Source Files
In some cases, you might have source code and other files that you want to reuse in a TimeStorm
project. To create a TimeStorm project from existing source files, perform the following steps:

1. Use the New Project wizard to create a project. Choose filenames and settings that will be appropri-
ate after your files have been imported. For example, if you have a main source file named
MyProject.c, create a C project (either TimeStorm or generic depending on your needs) named
MyProject. (You do not need to create a source code file.) TimeStorm creates default project files
as described in Section 3.2.4, Files Created by the New Project Wizard.

2. Open the Import wizard by choosing File > Import or by right-clicking on the project name in the
Navigator view and selecting Import. From the list labeled Select an import source, choose File
system. On Windows systems, TimeStorm also supports adding files to existing projects by drag
and drop. Drag the icon representing the file and drop it onto the project name in the C/C++
Projects view.

3. Specify the files to import on the next panel. The Import wizard allows you to browse the local file
system for the directory containing the source files. You can import some or all of the files from the
source directory. In the Into folder field, specify the project directory that you created in the first
step. You cannot specify a project that does not exist or that is not known to this instance of the
workbench.

Note:
Do not import a main makefile from an old project into a TimeStorm project. TimeStorm will
overwrite your makefile when the project is updated. You can use supplemental makefiles to
customize your project as described in Section 4.6, Makefile Customization.

When you finish the Import wizard, your new project, based on your old source files, is available in
TimeStorm IDE.
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TimeStorm 3.2.2 projects are compatible across operating systems. For example, no migration is re-
quired to use a TimeStorm 3.2.2 project from a Linux-hosted system on a Windows-hosted system, or
vice versa, as long as both systems use the same version of TimeStorm.

3.3 Using TimeStorm with Version Control
Systems

TimeStorm IDE is compatible with many popular version control systems. Detailed information about
establishing and maintaining files in a revision-controlled environment is included in the Workbench
User Guide online help.
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Chapter 4 - Building and Compiling
Projects

This chapter explains procedures that are used for building TimeStorm TimeStorm C and C++ projects.
It explains how to install toolchains and add them to the workbench for use with TimeStorm projects. It
also explains build configurations and how to use them to compile TimeStorm C and C++ projects.

Other types of projects in TimeStorm do not use toolchains or build configurations, and other procedures
described in this chapter might not apply to these projects, which include generic managed make and
standard make projects in C and C++. Section 4.1.1, Makefiles, gives an overview of makefile features
in the various types of projects that you can create in TimeStorm. More information about building gen-
eric C or C++ projects is included in the C/C++ Development User Guide, which is part of TimeStorm’s
online help. Details about building Java projects are given in the Java Development User Guide online
help. (To view online help, choose Help > Help Contents from the workbench menu and then select the
online help set that you want to read.)

4.1 About Makefiles, Toolchains, and Build
Configurations

TimeStorm simplifies the process of building a C or C++ project by automating certain steps in the pro-
cess. Makefiles can be automatically created and maintained; toolchains encapsulate the cross-compiler
and other required tools for building and debugging software on a target system; and build configura-
tions provide a graphical interface to configure and use build settings.

4.1.1 Makefiles
A project’s makefile contains the instructions for building the project.

TimeStorm has the ability to automatically create and update makefiles for C and C++ projects. Make-
file management is one of the main distinctions among the different types of C and C++ projects that
TimeStorm can create, as shown in Table 4.1 and described in detail in Chapter 3, Creating Projects.

Table 4.1. Features of different C/C++ project types

C or C++ Project
Type

Makefile
Maintenance

Cross-compiler /
Toolchain

Build
Configurations

Supplemental
Makefiles

Managed make Automatic Not used Used Used (optional)

Standard make Manual Not used (can be
manually
specified)

Not applicable Not applicable

TimeStorm Automatic Used
automatically

Used Used (optional)

If you want to create and control the makefile for your project, you should use a generic, “standard
make” C or C++ project. With a manually maintained makefile, you must write the build settings into
the makefile instead of using build configurations, and you must specify the exact paths to the compiler
and other tools in your toolchain in order to use a cross-compiler.

Projects with automatically maintained makefiles allow you to specify custom options by creating sup-
plemental makefiles that are read into the main makefile at predefined points in the file. See Section 4.6,
Makefile Customization, for details.
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4.1.2 Toolchains
Toolchains include the tools required to compile your applications. Toolchains that you use with
TimeStorm for remote development allow you to compile your applications on one platform for use on
another platform. They include appropriate cross-compilers, debugging software, and other utilities that
are customized for your TimeStorm host operating system and for your target system.

For example, if you run TimeStorm on a Windows desktop system, you must use a cross-compiler tool-
chain on your TimeStorm host in order to create an application that runs correctly on a Linux target sys-
tem with a PowerPC processor.

Build configurations for TimeStorm projects specify which toolchain to use when building your project.
You can set different toolchains in different build configurations.

4.1.3 Build Configurations
TimeStorm uses build configurations to control how TimeStorm C and C++ projects are compiled and
built. A build configuration is a persistent collection of build settings. By switching from one build con-
figuration to another, you can change the build settings for your project.

Settings that you make in build configurations are written into the TimeStorm-managed makefile, which
is then used to build the project.

Build configurations also are used in generic managed make C and C++ projects, although their options
are slightly different.

4.2 Installing Toolchains
Toolchains that are delivered with Linux distributions provided by TimeSys include cross-compilers,
libraries, debuggers, and other files that are necessary for building and using projects from TimeStorm.

TimeStorm recognizes toolchains in two categories: TimeSys-provided toolchains, and user-defined
toolchains.

The setup steps required to use toolchains in the two categories are different. For a TimeSys toolchain,
you only need to install the toolchain on the TimeStorm system. For a third-party toolchain, you must
first install the toolchain and then use the Add Toolchain wizard from within the workbench to add the
toolchain to the TimeStorm environment.

(These setup steps do not apply to the native toolchain, which is included with the development environ-
ment on your host system and does not include a cross-compiler. TimeStorm automatically detects the
native toolchain on the TimeStorm host system.)

4.2.1 TimeSys Toolchains
TimeStorm is designed to automatically detect toolchains from Linux distributions provided by
TimeSys. If you use a Linux distribution provided by TimeSys, you only need to install the toolchain on
your TimeStorm system. Use the instructions in the Getting Started guide that came with your Linux
distribution from TimeSys.

Note:
TimeStorm does not automatically recognize toolchains from older Linux distributions from
TimeSys (prior to version 4.0). Obtain a more recent distribution for your target board, or im-
port the toolchain by using the Add Toolchain wizard. Some older TimeSys toolchains are not
completely compatible with TimeStorm features, mainly debugging.

You have the option to import a supported TimeSys toolchain as a user-defined toolchain. There are a
few situations where you might decide to do this. For example, if you have modified any of the compon-
ents in the toolchain, you might want to import it with a separate name to avoid overwriting the original
toolchain on your system.
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4.2.2 User-Defined Toolchains
If your target operating system is not a Linux distribution from TimeSys, you must take an extra step to
make your toolchain available to TimeStorm.

After installing the toolchain according to instructions provided with your distribution, you must start
TimeStorm and modify the list of toolchains in TimeStorm’s preferences settings. The Add Toolchain
wizard walks you through the process of defining a toolchain.

If you do not import the toolchain as described in this section, it will not be available for use in
TimeStorm projects.

The next section gives detailed instructions for adding a user-defined toolchain to your TimeStorm
workbench.

Note:
When using a toolchain that was not provided by TimeSys, you must ensure the toolchain’s
compatibility with TimeStorm and with the other elements of your development environment.
The toolchain must be GNU-based. Ensure that cross-compilers and other required utilities are
available on the appropriate path and have the correct permissions for access by the TimeStorm
user. In order to perform remote debugging in TimeStorm, the toolchain must include GDB
version 5.2.1 or later.

4.2.3 Adding a User-Defined Toolchain
This section describes the procedure for adding a third-party toolchain to your TimeStorm environment.

4.2.3.1 Installing the Toolchain
Install your toolchain according to directions provided in your distribution. If you use TimeStorm on a
Windows PC, you should install the toolchain in a path under your Cygwin directory. For example,
TimeSys toolchains for Windows systems are installed in paths like the following one:

C:\Cygwin\opt\timesys\toolchains

Remember that you must install the Windows version of your distribution’s toolchain in order to build
binaries on a Windows-based TimeStorm system. Linux toolchains typically are incompatible with a
Cygwin-based development environment.

4.2.3.2 Defining the Toolchain in TimeStorm Preferences
Start TimeStorm and choose Window > Preferences. The Preferences panel appears. Select
TimeStorm > Toolchains to display the list of toolchains that are recognized by TimeStorm, as shown
in Figure 4.1.
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Figure 4.1. The Toolchains list

Both TimeSys toolchains and user-defined toolchains appear in this list. However, TimeSys toolchains
that are automatically detected cannot be edited. If you want to modify tools or properties for a TimeSys
toolchain, you must add it as a user-defined toolchain.

To add a new user-defined toolchain, click the Add button. The Add Toolchain wizard starts.

The first step in the Add Toolchain wizard is to specify where the toolchain is installed. Use the Browse
button to specify the directory that contains the toolchain’s binary files. Figure 4.2 shows the completed
form.

Figure 4.2. Specifying the toolchain location
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You also can choose whether to allow more than one user to use the newly defined toolchain. Choose
one of the following options:

• Current workspace – If you choose this option, information about the toolchain is stored with the
workspace state files in the .metadata directory of the TimeStorm workspace. The toolchain is ac-
cessible to any TimeStorm user who starts TimeStorm with that workspace; however, the workspace
directory typically is stored in a user’s home directory and therefore may be accessible only to that
user. Refer to Section 2.1.2, Navigating Projects, Files, and Workspaces, for information about file
locations and the workspace directory. The default option is The Current workspace only.

• Current user – If you choose this option, information about the toolchain is stored in a file in the
home directory of the user who started TimeStorm, but outside of the current TimeStorm workspace.
TimeStorm creates the directory structure .timesys/timestorm/toolchains in the user’s home dir-
ectory to store toolchain information. This option allows a TimeStorm user to access a toolchain
from multiple different workspaces.

• All users on this computer – This option causes TimeStorm to store toolchain information in a loca-
tion outside of the user’s home directory. TimeStorm creates the directory structure
/etc/timesys/timestorm/toolchains to store toolchain information (on Windows, the /etc direct-
ory is in the Cygwin root directory). In this case, any user who runs TimeStorm on the local machine
can use the toolchain.
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Supported TimeSys toolchains are accessible by all users of the host computer.

Note:
If you need to change the scope of a TimeSys toolchain, you can import its files as a user-
defined toolchain in addition to having it detected automatically. You still need to give the
user-defined version a unique identifier. In this case, the toolchain will appear in toolchain lists
twice, once as the stock installed version with the default identifier and once as the user-defined
version with the identifier you assigned when you added it.

After configuring the options on this panel, click Next. TimeStorm reads the information in the specified
directory to identify the tools present in the toolchain distribution. Figure 4.3 shows the list of tools.

Figure 4.3. Verifying tools

Verify that the names and locations of the tools listed are correct. If you want to specify a different ver-
sion of a particular tool, edit the Path field to refer to a different executable.
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Tools that are labeled as required are used by TimeStorm. If a required tool is not present, TimeStorm
prints a warning message. You can define toolchains that do not include required tools; however, some
TimeStorm features will not function correctly with such toolchains.

The next panel, shown in Figure 4.4, allows you to modify the toolchain’s name and description. If your
toolchain has acceptable default values, modifying the name and description information is optional. (In
this case, the Finish button is enabled, as shown in Figure 4.3.) Click Next to change the toolchain’s
name and description.

Figure 4.4. Naming the toolchain

You can customize the name, description, and identifier for this toolchain. TimeStorm mainly uses the
toolchain identifier (ID) as an internal reference; the name and description are used to identify the tool-
chain to users.

Identifiers and names must be unique; that is, two different toolchains on one system cannot have the
same identifier or the exact same name.

Note:
If you share a project among multiple TimeStorm host systems, you must install any required
toolchains for the project on each computer that runs TimeStorm, and you must make sure that
each toolchain has the same ID on each system. In other words, each machine must use the
same ID to reference a local copy of the same toolchain. (This is different from having two dif-
ferent toolchains with the same ID on one machine, which is unsupported.)

After specifying the toolchain name, description, and ID, click Finish. The new toolchain now appears
in the list of toolchains, as shown in Figure 4.5, and is ready for use in TimeStorm projects.
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Figure 4.5. Added toolchain

4.2.4 Modifying Toolchains
Only toolchains that you have added can be edited and removed in this interface. When you select a
toolchain that can be modified, the Edit and Remove buttons are active. Figure 4.6 shows a toolchain
selection that can be edited.

Figure 4.6. A user-defined toolchain that can be edited
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When you select a toolchain that is read-only, the Remove button is disabled and a View button appears
instead of the Edit button. Figure 4.7 shows a selected toolchain that cannot be edited.

Figure 4.7. A read-only toolchain

The native toolchain and any installed TimeSys toolchains are read-only. They cannot be modified or
uninstalled from the TimeStorm workbench. Consult the documentation that was provided with your
toolchain to determine how to change these toolchains.

4.3 Using Build Configurations
Build configurations specify what settings the compiler and linker use for your projects. You can have
multiple build configurations for a project, including build configurations that yield applications for dif-
ferent target systems.

The New Project wizard automatically creates three different build configurations for a C or C++
project: Debug, Profile, and Release.

• The Debug configuration created by the New Project wizard includes extra information that helps
debugging tools work. For example, sections of the compiled program are correlated with the lines
of code that generated them. By default, TimeStorm sets the Debug configuration as the active con-
figuration and uses it for the first project build.

• The Profile configuration created by the New Project wizard includes information that enables GNU
gprof profiling in the resulting program.

• The Release configuration created by the New Project wizard includes only required information,
and optimizes code.

You can modify these settings. Also, when you create your own build configurations you do not have to
observe any particular standards. (Although you must copy an existing build configuration’s settings as
the starting point for your own build configuration, there is no limit to the modifications that you can
make after creating the configuration.)
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There are several ways to add and change build configurations. You can access build configurations to
modify them from the Build Configurations view (described in the next section), or from the project
Properties panel (as described in Section 4.3.5, Accessing Build Configurations from the Project Prop-
erties View).

Project-level build configuration settings, including the name of the output file and the basic syntax of
the build command, can only be modified from the project Properties panel.

4.3.1 The Build Configurations View
TimeStorm includes a Build Configurations view, shown in Figure 4.8, that displays all the available
build configurations for your project.

Note:
The Build Configurations view does not show build configurations for generic managed make
projects. Those projects’ build configurations can only be edited from the project Properties
panel as described in Section 4.3.5, Accessing Build Configurations from the Project Properties
View.

Figure 4.8. Build Configurations view

The Build Configurations view is part of the C/C++ perspective. If the Build Configurations view
does not appear in your workbench, choose Window > Show View > Other, expand the folder labeled
TimeStorm, and select Build Configurations.

From this view, you can add or remove build configurations, modify their properties, or start builds us-
ing a specific configuration.

The build configuration that is labeled Active is the default build configuration for that project, which is
used when you start a build without specifying a configuration.

Selecting an individual build configuration and right-clicking it displays a menu with relevant options,
as shown in Figure 4.9.
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Figure 4.9. Build Configurations menu

The menu includes the following options:

• Edit – Modify the settings in the selected build configuration. (Read Section 4.3.3, Editing a Build
Configuration, for details about these options.)

• New – Create another build configuration. (Read Section 4.3.2, Creating a New Build Configuration,
for details about these options.)

• Build – Start a build using this configuration. (You must also select a submenu option, Build,
Clean, or Rebuild, as shown in Figure 4.9.)

• Make Active – Set this build configuration as the default.

• Remove – Delete this build configuration.

4.3.2 Creating a New Build Configuration
To create a new build configuration, right-click on the project name or on an individual build configura-
tion. From the menu that appears, choose New. The window shown in Figure 4.10 appears:
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Figure 4.10. Creating a new build configuration

Enter a name and description, and select a configuration to copy. You can copy settings from any exist-
ing or default build configuration in the same project as the new build configuration.

If you select Default configuration, the default settings for the selected type of build configuration are
used. If you select Existing configuration, the actual settings for a build configuration in your project
are copied, including any modifications that you have made since the New Project wizard created the
build configurations.

For example, you might create a project, and then modify its Debug configuration to include verbose
compiler output. In that case, copying the Debug item from the Existing configuration section of the
Create configuration panel would give you a new configuration with verbose compiler output. Copying
the Debug item from the Default configuration section would create a new configuration without verb-
ose compiler output.

When you click OK, the new build configuration appears in the list, but its settings are identical to those
of the configuration that you copied. To customize the new configuration, use the procedure described in
Section 4.3.3, Editing a Build Configuration.

4.3.3 Editing a Build Configuration
To edit a build configuration, first select it in the list. The Edit Configuration button becomes

active in the Build Configurations view’s toolbar. You can edit a build configuration either by clicking
this button in the toolbar or by right-clicking the configuration and choosing Edit from the context
menu.

Use the panel shown in Figure 4.11 to edit a build configuration.
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Figure 4.11. Editing a build configuration

The Active configuration section is disabled when you are editing an individual build configuration.
The controls in this section only apply when you are editing a project’s build configurations by using the
project Properties panel.

Selecting items in the Configuration settings list displays the settings that you can change. In
Figure 4.11, the Toolchain item is selected and the toolchain menu is active.

Figure 4.12 shows the same panel with the GCC C Compiler category selected.
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Figure 4.12. Compiler settings

Selecting a category label (like GCC C Compiler) shows all of the current settings in that category as
they would appear in a command line. You can edit the command-line settings in the Command field,
or you can select the sub-items in the category to configure the individual options by using a graphical
interface.

Figure 4.13 shows the settings in the Debugging item.
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Figure 4.13. Compiler debugging settings

The command-line equivalent options appear in parentheses next to the items that you can select. For
example, the -g3 setting in the Debug Level field of Figure 4.13 also appears in the All options field in
Figure 4.12.

When you are finished setting build options, click Apply or OK to save your changes. The Cancel but-
ton closes the window without saving changes.

4.3.4 Setting the Default Build Configuration
A default build configuration is assigned for each TimeStorm C or C++ project. This configuration is
used when you start a build by using options that are not associated with a particular build configuration.
For example, right-clicking on the project name in the Navigator view allows you to build the project
but does not allow you to specify a build configuration.

To set the default build configuration, right-click on the configuration in the Build Configurations view
that you want to make the default and choose Make Active from the menu that appears.

To build your project with a non-default build configuration, start the build by right-clicking on the
build configuration name and selecting one of the build options from the menu.

4.3.5 Accessing Build Configurations from the Project
Properties View

Build configurations also can be modified from a project’s Properties panel. To access the project
Properties panel, right-click on the project directory in the C/C++ Projects view. Select Properties
from the resulting menu and then select C/C++ Build, as shown in Figure 4.14.

Building and Compiling Projects

42



Figure 4.14. Build configurations in project properties

To modify an individual build configuration from Project Properties, you must first select it as the de-
fault configuration for the project by choosing it in the Configuration field of the Active configuration
section. The settings in the Configuration settings section correspond to the selected configuration.

The Manage button allows you to modify settings that apply to all build configurations in the project.
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Figure 4.15. Project-level build config settings

The Manage panel, shown in Figure 4.15 allows you to add, delete, or rename build configurations for
the project in the Manage configurations section.

Details about other project properties are included in Section 4.5, Project Properties Settings.

4.3.6 Related Project Settings
C and C++ projects have project-level settings that also affect how the project is built. Section 4.5,
Project Properties Settings, gives details about the project properties settings that you can make for a
TimeStorm C or C++ project.

Project properties are analogous to file properties, where you can set build configurations for individual
files within a project. File properties are described in Section 4.4, Overriding Build Configuration Set-
tings for a File.
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4.4 Overriding Build Configuration Settings for a
File

In a TimeStorm C or C++ project, if you want to change how a particular file is compiled, you can
change the build settings for that file by modifying its properties. Settings in the file’s properties over-
ride the build configuration and project properties settings for that file.

To access file build settings, right-click on the file name in the C/C++ Projects view. From the menu,
select Properties. (Do not click the project icon, because that action would show the project’s proper-
ties, which are described in Section 4.5, Project Properties Settings.) The file’s Properties panel ap-
pears. Select C/C++ Build to display the panel shown in Figure 4.16.

Figure 4.16. File properties

In the C/C++ Build panel, you can modify compiler settings that are part of the currently active build
configuration. You can change code optimization, inclusion of debugging or profiling data, treatment of
warnings, and other command-line options. You also can modify the list of paths for file inclusions and
add, change, or remove preprocessor definitions.

The changes in this panel do not affect the build configuration itself; settings are only changed for the
selected file.

To clear file-specific settings and make the file subject to the same build configuration settings as the
rest of the project, click the Restore Defaults button and save the changes.
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4.5 Project Properties Settings
Each project has project-level settings that affect how it builds. Many of these settings are configured
during project creation in the New Project wizard, but they can be changed by using the project’s
Properties panel.

Individual files in a project also can have their own properties. For more information about per-file set-
tings, see Section 4.4, Overriding Build Configuration Settings for a File.

To access project properties, right-click on the project in a hierarchical view (for example, the C/C++
Projects view or the Navigator view) and select Properties from the menu. The project Properties
panel appears.

Figure 4.17. Project properties

Different types of projects have different properties. Figure 4.17 shows the properties for a TimeStorm
C application project.

The following settings are commonly available in TimeStorm projects. Details about these settings are
found in the TimeStorm Online Documentation and the C/C++ Development User Guide online help.

• Info – Lists read-only information about the project and its files, and allows you to set file encoding
for text files in this project.
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• Builders – Specifies the utilities used to build the project.

• Build Products (appears only if Target Configurator is installed) – Allows you to specify products
from this project for export to a Target Configurator RFS project. Refer to Section 4.5.1, Build
Products, for details.

• C/C++ Build (C and C++ projects only) – Allows you to modify build configuration settings.

• C/C++ Documentation (C and C++ projects only) – Displays a listing of additional C/C++ help, if
it is available, and allows you to select items from the list. This Eclipse item is not available cur-
rently in TimeStorm.

• C/C++ File Types (C and C++ projects only) – Allows you to set the file associations for various
file extensions.

• C/C++ Indexer – Lets you configure code indexing and problem reporting.

• Project References – Allows you to configure referenced projects to build when TimeStorm builds
this project automatically. These settings only apply to builds that TimeStorm initiates automatically.
Refer to the Workbench User Guide online help for additional information.

4.5.1 Build Products
The Build Products panel lets you specify installation paths to use when your project’s output is in-
cluded in a Linux root file system (RFS) as part of a Target Configurator System Configuration project.
This option only appears if the Target Configurator plug-in is installed.

For example, if your TimeStorm C application project produces an executable file that you want to in-
clude in the /usr/local/bin directory of your RFS, set that path in this panel. When you add the C
project to your system configuration project, the executable file that you specified is included in the path
that you set. You must still use Target Configurator’s RFS editor to add the contributing project to the
system configuration project and to include that package in the final RFS. For detailed information about
including a TimeStorm project’s output in a system configuration project, read the TimeStorm Target
Configurator Online Documentation.

Figure 4.18 shows the default setting for a C++ shared library project named cpp_shared_lib.

Figure 4.18. Shared Library Build Products

The Project Path column shows the directory in the current project where the built file is stored.
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The Install Directory column shows the path where the file will be installed as part of a System Config-
uration RFS. Figure 4.18 shows the project binary libcpp_shared_lib.so, which is stored in the Debug

subdirectory of the following project:

/workspaces/TimeStorm-workspace/cpp_shared_lib/Debug/libcpp_shared_lib.so

If the library project’s output is added to an RFS project, it will be added as:

/usr/local/lib/libcpp_shared_lib.so

4.6 Makefile Customization
TimeStorm automatically creates and maintains the main makefile for TimeStorm C and C++ projects.
TimeStorm updates the makefile before each build, as needed.

TimeStorm 3.2.2 maintains multiple makefiles, one corresponding to each build configuration.

4.6.1 Using Supplemental Makefiles
Because TimeStorm controls the makefile, you cannot change build settings for the project by directly
editing the makefile. TimeStorm overwrites the makefile changes with its own updates before building
the project.

Instead, to support makefile customization, TimeStorm’s dynamically generated makefile uses three
supplemental makefiles at specified points during its execution. By supplying these makefiles, which are
not modified by TimeStorm, you can customize the build process while taking advantage of automatic
makefile maintenance.

The three supplemental makefiles are the following:

• makefile.init – This file is called at the beginning of the makefile. It can be used to customize ini-
tialization.

• makefile.defs – This file is called after initialization but before objects are compiled. It can be used
to supply custom macro definitions.

• makefile.targets – This file is called at the end of the makefile. It can be used to supply custom-
ized target information.

These supplemental makefiles are called in TimeStorm C and C++ projects and in generic, managed
make C and C++ projects.

4.7 Compiling C and C++ Applications
Methods for compiling a C or C++ application in TimeStorm IDE vary depending on whether or not you
want to use the primary build configuration, and whether or not automatic builds are enabled. Details are
included in Section 4.7.1, Automatic Builds, and Section 4.7.2, Manual Builds.

When you build a C or C++ application, TimeStorm does the following:

• Updates the makefile – TimeStorm maintains makefiles for each build configuration that you use.

• Builds and links your code – TimeStorm automatically uses the cross-compiler and linker that you
specified in your build configuration.
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• Stores the output in a subdirectory of the project – TimeStorm creates a subdirectory in your project
directory with the name of the build configuration that you used. (This subdirectory is created the
first time that you do a build with a particular build configuration.) Output from the builds with that
configuration is stored in that subdirectory.

Figure 4.19 shows a project that has two build subdirectories. Each has its own makefile and output
files. Note that the project in Figure 4.19 was built with two different toolchains, one for ARM and one
for x86, producing binary files that are compatible with different processors.

Figure 4.19. A project with multiple builds

The steps for starting a build are detailed in the following sections.
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4.7.1 Automatic Builds
TimeStorm can be configured to automatically rebuild projects when their files are changed. In
TimeStorm 3.2.2, this option can only be set on a workbench level – that is, either all projects build
automatically, or no projects build automatically.

When you save a file and automatic builds are enabled, TimeStorm rebuilds the project that contains the
changed file. The build occurs as a background process. Build messages are displayed in the Console
view.

Note:
Deleting an output file is a project change that causes a rebuild, immediately replacing the out-
put file with a new version.

Automatic builds always use the active (default) build configuration. However, you can use a non-de-
fault build configuration, even for a project that has automatic builds enabled, by starting the build from
the Build Configurations view as described in Section 4.3.1, The Build Configurations View.

If you use Target Configurator to create kernel or kernel module projects, which take a long time to
build, you might prefer to disable the automatic build option. (By default, TimeStorm disables automatic
builds when you create a new kernel or kernel module project.)

To enable or disable automatic builds, use the Project menu in the main workbench toolbar to select
Build Automatically. When automatic builds are enabled, a check mark is displayed to the left of the
Build Automatically option.

When automatic building is enabled, the manual build options are disabled in the Project menu and in
the menu that appears when you right-click a project name in the C/C++ Projects or Navigator views.
Figure 4.20 shows the Project menu when automatic builds are enabled.

Figure 4.20. Automatic builds enabled for a project
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4.7.2 Manual Builds
If you do not want TimeStorm to build your project automatically, you can use the methods in this sec-
tion to build your project manually. The methods depend on whether or not you want to use the active
(default) build configuration.

You can compile the application using the active build configuration by choosing any of the following
build options:

• From the Navigator or C/C++ Projects view, right-click on the project name and select one of the
build options (Build Project or Rebuild Project) from the context menu. The Rebuild Project op-
tion is only available in the C/C++ Projects view.

• From the main workbench menu, select Project > Build All or Project > Build Project.

• From the Build Configurations view, right-click on the primary build configuration and select
Build > Build, Build > Clean, or Build > Rebuild from the menu.

To use a non-default build configuration, start your build by right-clicking on the build configuration in
the Build Configurations view. Select Build and one of the build options (Build, Clean, or Rebuild)
from the menu.

Note:
If automatic builds are enabled, build options on the project menu are disabled. Because
TimeStorm rebuilds the project every time a file changes, the output should always be current
and there is no reason to build manually. To perform a manual build, use the Build Configura-
tions view or turn off automatic builds as described in Section 4.7.1, Automatic Builds.
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Chapter 5 - Downloading and Running
Applications from TimeStorm

TimeStorm IDE uses launch configurations to store download and execution information for your ap-
plications. Although launch configurations are part of the basic Eclipse IDE, TimeStorm launch config-
urations are customized to support executing a program on a remote target.

Section 5.6, Debugging, includes basic information about debugging an application in TimeStorm. The
C/C++ Development User Guide online help includes additional information about TimeStorm’s debug-
ging tools.

5.1 C and C++ Launch Configurations
TimeStorm IDE includes customized launch configurations for C and C++ projects. TimeStorm launch
configurations have the ability to transfer your project’s output to the target system and remotely control
how the binary is executed. When you invoke a launch configuration, TimeStorm connects to your tar-
get system, transfers files, sets environment variables and other arguments that you have configured, and
executes your application or installs your library file.

Launch configurations allow you to download and deploy new copies of your application, library, or
kernel module without having to change any configuration settings.

After you create and save a launch configuration, it takes only a few mouse clicks to transfer and run
your application, or to start a debugging session with the new binary.

This chapter explains the launch configurations used to deploy C and C++ applications on a remote tar-
get system. Details about the launch configurations that execute applications on the local system can be
found in the Workbench User Guide and Java Development User Guide online help files. Procedures for
deploying kernels and kernel modules, which require the Target Configurator plug-in, are discussed in
the TimeStorm Target Configurator User’s Guide.

5.2 Accessing Launch Configurations
Access launch configurations for your current project by selecting Run > Run or Run > Debug from
the main menu. The two different choices show launch configurations in two different modes: Choosing
Run > Run accesses run mode, and choosing Run > Debug accesses debug mode.

You can access the launch configurations from the menu that appears when you right-click on a project
in the Navigator view, or by clicking the Run or Debug buttons on the toolbar, which are shown in
Figure 5.1.

Figure 5.1. Debug and Run toolbar buttons

5.2.1 Run and Debug Modes
Run and debug modes are slightly different. Although several of the configuration types appear in both
run mode and in debug mode, some configurations appear only in one mode.

Run and debug mode panels are cosmetically different, as well. Instead of a Run button, the debug
mode panel has a button labeled Debug. Also, different icons appear in the upper right corner in run
mode and debug mode.
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Figure 5.2 shows the panel that appears when you select Run > Run.

Figure 5.2. Accessing launch configurations (Run mode)

When you execute a configuration in run mode, files are copied to the target system (if applicable), and
the application is run, or the non-application binaries are deployed. When you execute a configuration in
debug mode, TimeStorm also connects to the target with the GDB debugging utility and opens the
Debug perspective (by default) to show the results.

The Perspectives panel, which appears in Figure 5.2, allows you to change the perspective that
TimeStorm opens when it executes a configuration of the selected type. To show the Perspectives pan-
el, you must select a configuration category (like C/C++ Remote or Java Application) in the left panel
and not select an individual configuration (like cpp_app).

5.2.2 The Configurations List
Launch configurations are listed by their application types. Use the C/C++ Remote option to run a
TimeStorm C or C++ project on a remote target. (This configuration also can be used with generic C and
C++ projects.)
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From the Configurations list, you can run an application by selecting one of its configurations and
clicking the Run or Debug button that appears at the bottom of the panel (see Figure 5.3). You also can
create, edit, or delete launch configurations from this list.

When you select a configuration from the list, its details appear in the right side of the window, and you
can edit its settings.

5.3 Creating Launch Configurations
To create a launch configuration, use the Configurations list to select the type of configuration that you
want to create and click the New button.

If you had a compatible project selected when you opened the launch configuration panel, that project’s
information is filled in by default in the new configuration, as shown in Figure 5.3. If the appropriate
project cannot be determined, the placeholder name New_configuration is used.

Figure 5.3. A new C/C++ Remote configuration

The properties that you set depend on the type of configuration that you are creating. This chapter gives
details for creating a C/C++ Remote launch configuration, because those configurations are customized
for use with a remote target system.

5.3.1 About the C/C++ Remote Launch Configuration
A C/C++ Remote launch configuration is used to install and run an executable C or C++ application on
a remote target system. If started in debug mode, the configuration can be used to debug the running ap-
plication.
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5.3.2 Main Panel Options
In the Main panel, you set the name of your project and of the executable. Both of these values are re-
quired. Figure 5.4 shows the main panel options for a C/C++ Remote launch configuration.

You can use the Browse button to search for your project name. After specifying the project, you can
use the Search Project button to select from the executable files within your project.

Figure 5.4. Main panel (C/C++ remote configuration)

When choosing the application to launch, you must specify its relative location in the project. Execut-
able files are stored in project subdirectories with the same name as the build configuration type that was
used to create the executable file. Applications that can be launched are stored in the project directory
under a subdirectory that describes the type of build configuration. The application in Figure 5.4 is a
Debug build and is stored in the subdirectory named Debug.

TimeStorm can assist you in locating suitable application binaries within your project. Figure 5.5 shows
the Program Selection panel, which appears when you click the Search Project button next to the
C/C++ Application field. The panel lists the available application binaries that you can select from the
Qualifier list, as shown in Figure 5.5. Select a binary from the Qualifier list and click OK.

Downloading and Running Applications from
TimeStorm

55



Figure 5.5. Finding application binaries

Most C and C++ projects include a Debug build configuration by default. To add other build configura-
tions, refer to the instructions in Section 4.3.2, Creating a New Build Configuration.
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5.3.3 Arguments Panel Options
In the Arguments panel, you can specify how the application executes and the values to pass to the ap-
plication. The Arguments panel is shown in Figure 5.6.

Figure 5.6. Arguments panel (C/C++ remote configuration)

The panel contains the following fields.

• C/C++ Program Arguments – These values are passed to the application when it is executed. Sep-
arate values with spaces or the separator required by your application. The values in this field are ap-
pended to the execution command that is defined in the Command to Execute field.

• Remote Working directory – This value specifies the path on the target from which the application
will run. TimeStorm switches to this directory before giving the execution command (the command
is specified in the next field).

• Command to Execute – This field specifies the command that TimeStorm uses to execute the ap-
plication on the target system. Be sure to include the correct path to the application file, which is in-
terpreted as relative to the working directory.

If you do not modify the Remote Working directory field, the command is executed from the home
directory of the user specified in the Target panel. The user’s home directory is represented by a
period, sometimes called a dot, (.) in the directory field. Alternatively, you can use an absolute path
starting with a (/) character.
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5.3.4 Environment Panel Options
The Environment panel, shown in Figure 5.7, allows you to set environment variable values on your
target system before running the application. Modifying this configuration is optional.

Figure 5.7. Environment panel (C/C++ remote configuration)

5.3.5 Debugger Panel Options
The Debugger panel, shown in Figure 5.8, allows you to configure debugging-related settings for the
configuration.

Figure 5.8. Debugger panel (C/C++ remote configuration)
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In the Debugger panel, you can set the following options:

• Toolchain – Choose the toolchain that you want to use from the drop-down list of defined tool-
chains. By default, the toolchain used for the project is displayed. The path to the debugger execut-
able is set automatically when you choose a toolchain from the list.

To use a debugger in TimeStorm, you must associate the debugger with a toolchain. You can asso-
ciate any debugger with a toolchain that you define. Refer to Section 4.2, Installing Toolchains, for
information about defining toolchains.

• Stop at main() on startup – Choose this option if you want execution to pause when your applica-
tion starts. This option is selected by default.

• Automatically track the values of variables – Check this box if you want to have the values of
variables displayed in the Variables view while your project is being debugged. This option is selec-
ted by default.

• Debugger Options – This section of the panel includes two tabs. The Main tab is described in
Section 5.3.5.1, Main Tab, and the Shared Libraries tab is described in Section 5.3.5.2, Shared Lib-
raries Tab.

5.3.5.1 Main Tab
The Main tab of the Debugger panel, shown in Figure 5.8, contains the following fields:

• GDB debugger – Select the debugger that corresponds to your target system. This field automatic-
ally displays the default debugger for the toolchain that you have installed. Use the Browse button if
you want to use a different debugger.

Debuggers are associated with toolchains; when you define a toolchain, you can specify the debug-
ging software that you want to use with that toolchain. TimeStorm requires GDB version 5.2.1 or
higher for remote debugging, along with compatible software on the target system. Refer to Sections

Downloading and Running Applications from
TimeStorm

59



2.5 and 2.6 in Getting Started with TimeStorm for details about debugging software for the target
system.

• GDB command file – This field allows you to specify a .gdb-command file by using the Browse
button. The debugger will execute the commands that are specified in the file.

• GDB Server Port – This field lets you specify the port number used for debugging.

5.3.5.2 Shared Libraries Tab
The Shared Libraries tab is shown in Figure 5.9.

Figure 5.9. Debugger panel – Shared Libraries tab (C/C++ remote configuration)

The Shared Libraries tab includes the following options:

• Directories – This field automatically displays the shared library path for your project. Use the Add
button if you want to add other paths. Use the Up and Down buttons to move through the list of dir-
ectories. Use the Remove button to delete a path.

• Load shared library symbols automatically – Select this checkbox if you want these library sym-
bols to be displayed as loaded in the Shared Libraries view and if you want the debugger to hit any
breakpoints in the shared library project. This option is selected by default.

• Stop on shared library events – Select this checkbox if you want the debugger to stop at shared lib-
rary events, even before it hits breakpoints in the source code. This option is not selected by default.
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5.3.6 Source Panel Options
The Source panel, shown in Figure 5.10, displays the locations of source files for your project. This list
forms the search path for the debugger when this launch configuration is used in debug mode.

Figure 5.10. Source panel (C/C++ remote configuration)

Directories at the top of the list are searched before directories at the bottom. You can add, edit, remove,
or reorder list items by using the buttons at the right side of the list. You can also restore the default path
by using the Restore Default button.

Selecting the Search for duplicate source files on the path checkbox causes TimeStorm to detect
identically named source files when attempting to match executing binary code with source code. Dur-
ing debugging, if more than one source file seems to match the binary, TimeStorm displays a message
and asks the user to identify which file to use. For example, TimeStorm would be unable to determine
which of the following files matched an executing binary named foo:

my_cpp_app/orig/foo.c
my_cpp_app/new/foo.c

Assuming that both of these files are in the source path, TimeStorm asks which source file to use for de-
bugging.
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5.3.7 Target Panel Options
The Target panel, shown in Figure 5.11, allows you to configure a connection between the host and the
target system. When you run the launch configuration, TimeStorm makes the connection to the target
system in order to execute your application.

Figure 5.11. Target panel (C/C++ remote configuration)

In the Target panel, use the drop-down menu to select a target that you have registered with TimeStorm.
If you have not yet registered a target, click Manage targets to open the Targets management utility.
Refer to Appendix E in Getting Started with TimeStorm for details about using this utility. Targets that
are registered with TimeStorm using this utility can be used with TimeStorm and any of its plug-ins.

Note:
Telnet and FTP timeout values for launch configurations can be set from the TimeStorm Pref-
erences panel. From the main TimeStorm menu, select Window > Preferences and open the
TimeStorm > Launch Timeout item.

If you have problems maintaining a connection to the target when using this launch configura-
tion, consider increasing the value in the timeout setting.

Settings made in the Launch Timeout panel only affect launch configurations; they do not af-
fect timeout settings for the Console view or for any other use of Telnet or FTP.
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5.3.8 Download Files Panel Options
In the Download Files panel, shown in Figure 5.12, you can specify additional files to download to the
target along with the application, and you can set destination directories for the downloaded files.

Figure 5.12. Download Files panel (C/C++ remote configuration)

The application specified in the File field is listed as [Target Program].

Note:
If you transfer files by using FTP, the actual destination directories depend on the configuration
of your FTP software. In some cases, directories specified in this panel are appended to the
user’s home directory on the target.

Use the Add File button to specify additional files to transfer along with the application. These files are
transferred every time you transfer the application file.

To change where the application (or any other file in this list) is installed, select it and click Edit to
change its destination directory.

To eliminate a file from the items to download, select it in the list and click the Remove button.

The Download Now button copies files immediately, without running the application.

The Test button checks the connection to the target system to determine whether the transfer method
you have chosen is correctly configured.

Note:
Downloaded files overwrite any identically named files on the target system without giving a
warning. TimeStorm also creates the destination directories specified in this panel, if they do
not already exist on the target system.

5.3.9 Common Panel Options
In the Common panel, shown in Figure 5.13, you can select whether to make this launch configuration
available to other workspaces. You also can set options to switch perspectives in the workbench when
using this configuration, and to add the launch configuration to the menus.
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Figure 5.13. Common panel (C/C++ configuration)

Typically, launch configurations are saved with the workspace and are not accessible from other work-
spaces. This setting corresponds to the Local file option on this panel. If you want to share this launch
configuration with other users, including using it in a shared source control system, select Shared file. A
shared launch configuration is saved as a .launch file that can be imported by other workspaces. Op-
tionally, pick a location where the launch configuration file is copied so that it can be used by others.

If you want this launch configuration to be available from the Run menu, select one or both checkboxes
under Display in favorites menu. This setting forces the launch configuration to be available from the
Run History or Debug History submenu, regardless of how recently you have used it. Changing these
settings is optional.

The Launch in background option causes TimeStorm to execute the configuration tasks in a back-
ground thread. If this checkbox is not selected, the download and execution prevent you from perform-
ing other TimeStorm tasks until the configuration has completed its run. Background execution is the
default setting.

The other options in this panel are Eclipse features that are not currently supported in TimeStorm.
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5.4 Running an Application from TimeStorm
After you have created a launch configuration, you can use it to run your application and to start a de-
bugging session, if you use a debug configuration. Although different launch configurations have differ-
ent effects, all configurations are executed in the same way.

If you launch your configuration from debug mode by using the Debug History menu or the Debug but-
ton, it starts a debugging session, in addition to deploying the application or other binary files.

To execute your launch configuration, do one of the following:

• Select the launch configuration from a submenu of the main Run menu. Refer to Section 5.3.9,
Common Panel Options, for information about displaying configurations in the Run History or
Debug History menus.

• Open the launch configurations panel, select the configuration that you want to use, and click the
Run button (or the Debug button, in debug mode) that appears at the bottom right of the window,
next to the Close button, as shown in Figure 5.14.

Figure 5.14. Launch configurations (debug mode)

The Run or Debug button becomes active after the configuration is completely configured, without
errors, and saved. Click Apply to save the configuration.
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• From the Navigator view, right-click your project name and select a launch configuration from the
menu that appears. Figure 5.15 shows configurations on the Debug menu. If your configuration does
not appear on the menu, select Run (or Debug in debug mode) and select it from the display.

Figure 5.15. Debugging an application from a menu
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5.5 Console View
The Console view allows you to establish a Telnet, SSH, or serial connection to your target. To do this,
click the Open Console button in the Console view’s toolbar and select Target Console from

the menu. The Choose a target dialog appears. Use the drop-down menu to select your target, as shown
in Figure 5.16.

Figure 5.16. Choose a target dialog

If you do not have any targets registered, click Manage targets to register a target with TimeStorm.
Refer to Appendix E in Getting Started with TimeStorm for more information about registering targets.

After you make a selection, the connection type that will be used (Telnet, SSH, or serial) is displayed in
the dialog, along with the IP address of the selected target. Click OK to start to make the connection.

TimeStorm attempts to make the connection to the target, and a session opens in the Console view, as
shown in Figure 5.17.
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Figure 5.17. Console view

The buttons in the Console view have the following meanings:

Terminate button – Stops a Telnet, SSH, or serial session to a target.

Remove Terminated button – Deletes the output of a terminated Telnet, SSH, or serial session
and closes the console window. This button is activated only after you have used the Terminate
button.

Clear Console button – Deletes all of the console output for a session with a target.

Scroll Lock button – Click this button to stop the fast scrolling of the console output. To re-
sume the fast scrolling, click the Scroll Lock button again.

Pin Console button – When multiple sessions are open, use this button to force a particular ses-
sion to stay on top.

Display Selected Console button – Toggles between multiple open sessions with the target.

Open Console button – Opens a Telnet, SSH, or serial session to a target. You can open mul-
tiple sessions, and either view them one at time or tile them so that they do not overlap.
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5.6 Debugging
TimeStorm includes built-in debugging tools that work with local or remote applications. TimeStorm’s
debugging features can be accessed by launching an application with the Debug command and switch-
ing to the Debug perspective. This perspective includes tools for showing variable values, stepping
through code, and using breakpoints. The C/C++ Development User Guide online help includes more
information about TimeStorm’s debugging tools.

5.6.1 Prerequisites for Debugging
Debugging in TimeStorm requires appropriate debugging software. The toolchain installed on
TimeStorm must include the GNU debugger (GDB), version 5.2.1 or higher. (TimeStorm also was
tested for compatibility with GDB 6.2.) The target system’s root file system must include matching gdb-
server software. TimeStorm uses the toolchain’s GDB application to contact the target system and re-
ceive information from gdbserver.

The GDB and gdbserver software is customized for your target’s architecture, and the versions of GDB
and gdbserver must be compatible. If your target Linux distribution does not include appropriate debug-
ging software, contact your distribution’s provider for more information. Linux distributions from
TimeSys that are version 4.0 and later include appropriate GDB and gdbserver software.

If you use Target Configurator to create kernels or kernel modules, read the TimeStorm Target Configur-
ator User’s Guide to learn about the additional steps that are required to debug a Linux kernel or a ker-
nel module.

Remote debugging capabilities use the Telnet, SSH, or serial connection that is configured in the Target
panel of the launch configuration. If those settings are not correct, remote debugging will not function.
Refer to
Section 5.3.7, Target Panel Options, for additional information about these settings.

Debugging capabilities might be limited if your application was not built with debugging data enabled.
TimeStorm launch configurations do not prevent you from using a Release build or other non-debugging
build in a debugging configuration (Figure 5.14 shows an example), but you should typically use a bin-
ary application that was compiled with debugging information.
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5.6.2 The Debug Perspective
The Debug perspective is shown in Figure 5.18.

Figure 5.18. Debug perspective

Switch to the Debug perspective by clicking the Open Perspective button on the toolbar, or by select-
ing Window > Open Perspective > Debug.

TimeStorm attempts to automatically switch to the debugging perspective when you execute a launch
configuration in debug mode. Executing a launch configuration is described in Section 5.4, Running an
Application from TimeStorm. Debug launch configurations also are mentioned in Section 5.2.1, Run and
Debug Modes.

Procedures for debugging Linux kernels and kernel modules are described in the TimeStorm Target
Configurator User’s Guide.

Downloading and Running Applications from
TimeStorm

70



Note:
To debug a Linux application in TimeStorm, GDB software version 5.2.1 or higher is required,
along with compatible software on the target system as described in Section 5.6.1, Prerequis-
ites for Debugging.

The Debug perspective includes the following specialized views and tools.

5.6.2.1 The Debug View
The view at the upper left part of the workspace in Figure 5.18 is the Debug view. Use the buttons at the
top of the view to start, suspend, or step through your application. You also can disconnect from the tar-
get system and perform other debugging-related tasks. Position the mouse pointer above one of the but-
tons to show a tool tip describing the button’s function.

5.6.2.2 Data Views
The upper-right part of the workspace includes views that show data related to your application. Click
the tabs at the top of the views to switch from one view to another. The views allow you to investigate
things like variable values, register contents, expressions, the contents of specific memory addresses,
and other useful data related to your application and target system.

5.6.2.3 Editor
The center of the perspective shows a source code editor that you can use to display and modify your
program or other code. Unlike other code editors, the debug perspective editor allows you to set break-
points or bookmarks in the displayed code. Double-click in the gray margin at the left of the instruction
where you want to set a breakpoint.

5.6.2.4 The Run Menu
The Run menu in the Debug perspective includes options to set breakpoints and watch points, among
other debugging-specific items.

5.6.2.5 Console and Tasks Views
The Debug perspective includes the Console view and the Tasks view, which also appear in other per-
spectives. The Console view shows output from your application and lets you connect to your target.
The Tasks view shows errors and warnings processed by TimeStorm.

5.6.3 Starting a Debugging Session
To start debugging an application or other project in TimeStorm, you must create a launch configuration
and execute it in debug mode, as shown in Figure 5.19.
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Figure 5.19. A launch configuration in debug mode

To open the launch configurations panel in debug mode, select Run > Debug from the main menu, or
click the toolbar debug button (shown in Figure 5.1).

Make sure that appropriate settings are configured in the Debugger tab of the launch configuration. Se-
lect the configuration that you want to launch and click the Debug button to start the session.

The GNU debugger (GDB) has the capability to read an initialization file named .gdbinit when starting
a debugging session. Specify that file in the GDB command file field in the Main tab of the Debugger
panel. When TimeStorm starts a debugging session with GDB, it uses that file. You must create the
.gdbinit file; it is simply a text file that contains GDB commands.

5.6.4 Debugging Shared Libraries
A few extra steps are required to debug shared libraries in TimeStorm.

Because there is no meaningful way to launch or debug a shared library project by itself, you should cre-
ate a rudimentary application project to use for debugging a shared object file. Add calls into the shared
library as part of the executable application. Then, create and launch a debug configuration for the ex-
ecutable. During the application debugging session, you can step into the library and debug its code.

The remainder of this section describes the steps in more detail.
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5.6.4.1 Create an Executable that Calls the Library
You must create an application project that includes calls to the shared library that you want to debug,
by modifying its source code and updating its build configuration to link to the library project.

Use the New Project wizard to create a TimeStorm C project. When creating the project, be sure to use
the following settings:

• Specify the same toolchain that your library project uses so that both can run on the same platform.

• Create an initial source code file for the application project. The valid C application that TimeStorm
creates is typically a convenient starting point for adding your library calls.

After creating the project, modify the source code file to call the shared library from the other project.

1. Double-click the <project_name>.c file to open it in a code editor.

2. Include the header file for the shared library project (typically main.h).

3. Add calls to your library in the application code.

Figure 5.20 shows the modified file from a TimeStorm C project named lib_tester.

Figure 5.20. An executable project that calls a shared library
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The code in the lib_tester.c file references the sayHello function from a shared library.

You can save this source code file; however, the application will not build correctly until you have mod-
ified the build configuration to define the components that you have added to the source code.

Modify the project’s Debug build configuration as follows. This configuration is created and set as the
default by the New Project wizard. (Section 4.3, Using Build Configurations, includes detailed informa-
tion about modifying build configurations.)

1. In the Build Configurations view, select Debug and click the Edit button. The Edit Build Con-
figuration panel appears.

IN the GCC C Compiler settings list, select Directories. Add the path to the shared library project
in the Include paths list.

Figure 5.21 shows the completed form, with a reference to a shared library project named
my_shared_library.

Figure 5.21. Compiler setting to reference a shared library path

2. In the GCC C Linker settings list, select Libraries.

a. Add the library name to the Libraries (-l) field. TimeStorm shared library projects typically
create a binary file named lib<project_name>.so; only the <project_name> section of the
file is used in this field.

b. Add the path to the actual library binary in the Library search path (-L) field. You must spe-
cify the subdirectory (typically, Debug) that contains the file being used. This path will be in
the form /workspaces/TimeStorm-workspace/<project_name>/Debug.

Figure 5.22 shows the completed Libraries section for the lib_tester project (referencing
the my_shared_library project).
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Figure 5.22. Library linker settings

3. Click OK to save the modifications and exit the Edit Build Configuration panel.

After updating the Debug build configuration, the application project should build without errors. If you
have not already done so, save your modifications to the source code file and rebuild the project.

5.6.4.2 Create a Debug Launch Configuration for the Executable
Next, create a launch configuration to use for establishing a debugging session for the application
project.

1. Create a new launch configuration in debug mode:

a. Select the application project in the C/C++ Projects view.

b. From the main menu, choose Run > Debug.

c. In the Configurations list, select C/C++ Remote and click New.

2. Configure appropriate settings for your system, as described in Section 5.3, Creating Launch Con-
figurations.

3. In the Source panel, add the shared library project to the Source Lookup Path list by clicking the
Add button. Select the source for this project and click OK twice. The path is added to the Source
Lookup Path list, as shown in Figure 5.23.
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Figure 5.23. Source lookup path for the referenced library

4. In the Download Files panel, add the lib_tester file and the shared library binary file to the list of
files that will be transferred to the target by using the Add File button. Select the files and click
OK twice. The files are added to the Download Files tab, as shown in Figure 5.24.

Figure 5.24. Files for download to the target system

5. In the Environment panel, add the environment variable LD_LIBRARY_PATH to reference the direct-
ory on the target system where the library binary will be copied. Click New, enter the variable and
value, and click OK. The information is added, as shown in Figure 5.25.
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Figure 5.25. Library path variable for the target system

6. Click OK to save the modified launch configuration and exit the configuration dialog.

5.6.4.3 Start the Debugging Session
After completing the setup steps, you can start the debugging session in TimeStorm. Use the Run >
Debug menu to launch the configuration for the application project in debug mode.

The debugging session opens and begins debugging the application. To show code for the shared library,
use the Step Into function in the Debug view.

You can also see shared library data in the Shared Libraries view. This view is updated while the ap-
plication is executing if the Load shared library symbols automatically checkbox is selected in the
Shared Libraries tab in the Debugger panel.

You can also update the Shared Libraries view by clicking the Refresh View’s Content button or by
clicking the Automatically Refresh View’s Content button. These buttons are located in the toolbar of
the Shared Libraries view. Figure 5.26 shows the automatic refresh button on the left and the manual
refresh button on the right.

Figure 5.26. Auto-refresh and refresh buttons

The C/C++ Development User Guide online help includes more detailed information about the Debug
view and debugging tasks.
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Chapter 6 - Tutorial: Creating a
TimeStorm Project

This chapter is a tutorial that walks you through the steps for creating a basic application using
TimeStorm IDE, building it, and running it on the target system. Details about TimeStorm features are
available in the other chapters of this document and in the Workbench User Guide online help and
TimeStorm Online Documentation.

This example uses a Linux distribution from TimeSys (version 6.0) operating system on the target. If
you use a different Linux distribution on your target, refer to the documentation provided with your
Linux distribution for details about how to install, configure, and access software on your target.

6.1 Overview
This tutorial uses TimeStorm to create a C application.

The target is an MPC885ADS development board. It has an Ethernet connection to the Windows PC
host. The target uses a Linux distribution provided by TimeSys. The target’s root file system (RFS) is
hosted on the TimeStorm host machine and is exported as /opt/timesys/linux/6.0/ppc8xx-std/rfs.
The MPC885ADS toolchain is installed on the TimeStorm host. Details about installing and configuring
the target RFS and other settings are included in the Getting Started guide provided with Linux distribu-
tions from TimeSys. (If you use another Linux distribution on your target system, refer to the document-
ation provided with your Linux operating system for setup information.)

Before creating a project, you must install and start TimeStorm according to the instructions in Getting
Started with TimeStorm. Also, make sure the toolchain for your target is installed on your host before
starting the New Project wizard. Installing toolchains is documented in Chapter 4, Building and Compil-
ing Projects.

Before running an application on the target system, you must set up the target and configure communic-
ations according to the instructions provided with your hardware and software.

6.2 Using the New Project Wizard
TimeStorm’s New Project wizard collects the required information and then creates a project based on
the information that you supply.

6.2.1 Start the New Project Wizard
Start the New Project wizard by using the File > New > Project menu item or by clicking the new
project wizard button in the toolbar, shown in Figure 6.1.

Figure 6.1. New Project wizard button

Optionally, use the button’s drop-down menu to select the Project option.
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6.2.2 Choose a Project Category and Type
First, you must select what type of project to create. TimeStorm can create many different types of
projects, in several different programming languages. The interface is shown in Figure 6.2.

1. Expand the C item by clicking the + sign at the left of the project folder icon. (Depending on your
operating system’s window manager, an arrow or another symbol might be used instead of the +
sign.)

Figure 6.2. Choosing a project type

2. Select TimeStorm C Project, then click Next.
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6.2.3 Name the Project
The next panel, shown in Figure 6.3, requires a project name. Type the name tutorial and click Next.

Figure 6.3. Project name

6.2.4 Specify the Project’s Type and Toolchain
In the next panel, shown in Figure 6.4, you can customize the project output type (Executable, Static
Library, or Shared Library) and specify a toolchain to use for the initial build configurations.
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Figure 6.4. Project type and toolchain

1. From the Project Type drop-down menu, select Executable.

2. Use the Toolchain drop-down menu to select your toolchain. The name listed for your toolchain
might be different from the name in this example if you have a different distribution, or if you gave
the toolchain a different descriptive name.

3. Make sure that the checkbox labeled Create a project with an initial source code template is se-
lected, and click Next.

6.2.5 Specify a Project Template
In the next panel, shown in Figure 6.5, you can choose a template for either a hello embedded c applica-
tion project or for a simple c multi-threaded application project. Select the hello embedded c template,
and click Finish to create the project.
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Figure 6.5. Selecting a template

6.2.6 Files Created
The New Project wizard creates a project directory named tutorial that contains the project files, in-
cluding the initial source code file. The project directory is located in the workspace directory that you
used when you started TimeStorm (as shown in Figure 6.3).

Three different build configurations using the selected toolchain are created as part of the project cre-
ation process: Debug, Profile, and Release.

If automatic building is disabled for your workspace, or if you did not create a project source file, a
build does not occur. Automatic builds also are disabled for the entire workspace when you create a ker-
nel or kernel module project (these project types require the Target Configurator plug-in).
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6.2.7 Build the Project
TimeStorm includes a Build Configurations view that shows the available build configurations for your
project. Open the Build Configurations view as follows:

1. Click the tab labeled Build Configurations at the bottom of the C/C++ perspective to bring the
Build Configurations view to the front.

If the tab is not visible, you can open it. Choose Window > Show View > Other from the main
toolbar menu. Expand the folder labeled TimeStorm, and select Build Configurations.

2. TimeStorm creates build configurations named Debug, Profile, and Release with each new C or
C++ project. More information about these build configurations is included in Chapter 4, Building
and Compiling Projects.

Click the + sign next to tutorial to show the three existing build configurations.

3. Build the project by using the Debug build configuration. In the Build Configurations view, ex-
pand the tutorial project. Select the Debug [Active] build, right-click, and select Build > Build,
as shown in Figure 6.6.

Figure 6.6. Building the Project
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6.2.8 Files Shown after the Build
After the build compete, the project files appear in the C/C++ Projects view, as shown in Figure 6.7.

Figure 6.7. Project files

In the C/C++ Projects view, expand tutorial by clicking the + sign at the left of the project folder
icon. (Depending on your operating system’s window manager, an arrow or another symbol might be
used instead of the + sign.) You also can expand other items to show their contents.

The file structure of the new TimeStorm C application project includes the following:

• tutorial directory – The top-level directory for the project is represented by an icon that resembles
a hanging file folder.

• Binaries directory – Although it looks like a directory, this folder is actually a virtual directory that
shows only binary files from the project. This virtual directory makes it more convenient for you to
locate binary files.

• Includes directory – The Includes directory is a subdirectory of the project that shows the tool-
chain location used for the Debug build configuration.

• Debug directory – The Debug directory is a subdirectory of the project that shows the output of builds
using the Debug build configuration.
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• tutorial binary – This executable file is the product of the automatic build. You can change the
output filename as part of the project’s build settings (read Chapter 4, Building and Compiling
Projects for additional information).

• tutorial.o, objects.mk, sources.mk, subdir.mk, and tutorial.d – These intermediate files are
created during project compilation.

• makefile – The project makefile. The makefile is automatically updated by TimeStorm when files
change.

• tutorial.c – A prototype source code file. The subordinate items shown in the C file are not files,
but actually represent structural elements of the source code file.

6.3 Editing Source Files
TimeStorm edits files by starting the editor associated with that type of file in the workbench. Refer to
the Workbench User Guide online help for information about specifying default editors.

In this part of the tutorial, you will open and edit a source code file.

6.3.1 Open a Source Code Editor
The tutorial.c file is the main program file for your project. By default, the following file is created:

#include <stdio.h>

int main(int argc, char** argv) {
int i = 0;

printf("Hello, embedded world!\n");

for (i = 0; i < argc; i++) {
printf("%2d : %s\n", i, argv[i]);

}

return 0;
}

In the C/C++ Projects view, double-click tutorial.c to open it in a source code editor, as shown in
Figure 6.8.
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Figure 6.8. The tutorial.c file open for editing (C/C++ perspective)

6.3.2 Modify the Source File

1. In the tutorial.c file in the source code editor, select Hello, embedded world! and change it to
Welcome to TimeStorm!

When you modify the file, an asterisk (*) appears next to the filename in the editor label, as shown
in Figure 6.9. The asterisk indicates that the file has changed since it was last saved. The left mar-
gin of the changed line is highlighted in purple.
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Figure 6.9. The modified tutorial.c file

2. Save the file by right-clicking in the editor and selecting Save, or by selecting File > Save from the
main menu bar.

Alternatively, you can use the Save button in the toolbar.

In the next step, you will customize how your application is built.

6.4 Building and Compiling
TimeStorm C and C++ projects are built and compiled according to build configurations. (Additional in-
formation about build settings is included in Chapter 4, Building and Compiling Projects.)

6.4.1 Open the Build Configurations View
The Build Configurations view should already be in front. If it is not visible, click the tab labeled Build
Configurations at the bottom of the C/C++ perspective to bring it to the front, as shown in Figure 6.10.
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Figure 6.10. Build Configurations view

For this sample application, you will create a new build configuration that enables both debugging and
profiling. You also will enable more verbose reports of warnings.

6.4.2 Create a Custom Build Configuration

1. In the Build Configurations view, right-click the Debug build configuration in the Build Config-
urations view and choose New to create a new build configuration, as shown in Figure 6.11.

Figure 6.11. The Build Configurations menu
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The panel shown in Figure 6.12 appears.

Figure 6.12. Creating a build configuration

2. In the Name field, enter the name debug-with-profile.

3. In the Description field, enter the name tutorial-debug-build.

4. Click the Default configuration radio button and select Profile from the drop-down list.

5. Click the Existing configuration radio button and select Debug from the drop-down list.

The completed panel will look like the one shown in Figure 6.13.
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Figure 6.13. The completed Create configuration panel

6. Click OK.

TimeStorm creates the new build configuration, using the same settings as the Debug configuration that
you specified. In the next step, you will edit the new configuration to change its settings.
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6.4.3 Modify the New Build Configuration’s Settings

1. Right-click the new build configuration named debug-with-profile, and select Edit from the
menu, as shown in Figure 6.14.

Figure 6.14. Editing the new build configuration

The panel shown in Figure 6.15 opens.
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Figure 6.15. Edit Build Configuration panel

2. In the GCC C Compiler section of the Configuration settings list, select Debugging.

3. Select the checkbox labeled Generate gprof information (-pg), as shown in Figure 6.16.
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Figure 6.16. Debugging options

4. Next, change the level of output reporting. In the GCC C Compiler section of the Configuration
settings list, select Miscellaneous.

5. Select the checkbox labeled Verbose, as shown in Figure 6.17.
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Figure 6.17. Miscellaneous options

6.4.4 Save the Build Configuration
Click OK to save the new build configuration and exit.

6.4.5 Compile the Application
Next, compile the application using the new build configuration.

In the Build Configurations view, right-click on the debug-with-profile item. Select Build >
Rebuild from the context menu, as shown in Figure 6.18.
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Figure 6.18. Starting a build with the new build configuration

During the build, TimeStorm shows status messages in the Console view.

When the build completes, a new directory named debug-with-profile is added to the C/C++ Projects
and Navigator views, as shown in Figure 6.19. The tutorial binary in that directory was created using
the new build configuration.

Tutorial: Creating a TimeStorm Project

95



Figure 6.19. The workbench after the build

6.5 Downloading and Running the Application
In this section, you will download the compiled application to the target and run it.

6.5.1 Open the Launch Configurations Panel
You can access launch configurations by selecting Run > Run from the TimeStorm menu.

Alternatively, you can use the Run button on the main menu.
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Note:
Clicking the Run button without making a selection from the drop-down menu causes
TimeStorm to run the launch configuration that you last launched. If no configurations exist, or
if you have not yet launched any configurations from this workspace, clicking the button opens
the launch configurations dialog.

The Run panel appears.

6.5.2 Create a New C Remote Launch Configuration
The sample application runs on a remote target, so you will use the C/C++ Remote application launch
configuration.

1. In the Configurations list, click on C/C++ Remote to select it.

2. Click the New button to create a new launch configuration, as shown in Figure 6.20.

Figure 6.20. Creating a launch configuration

The name and project are automatically filled in with the project that was selected when you opened the
launch configuration dialog.
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6.5.3 Specify the Application To Run
In the C/C++ Application field, use the Search Project button to select the application named ppcbe -

/tutorial/debug-with-profile/tutorial. When the application is displayed in the
C/C++ Application field, TimeStorm truncates it to debug-with-profile/tutorial.

Use the tabs to select and configure the options that are described in the following sections.

No configuration changes are required in the Arguments, Environment, Debugger, Source, and
Common panels. Click the arrow, shown to the right of the Debugger tab in Figure 6.20, to switch to
the Target panel.

6.5.4 Configure Target Communication
The Target panel settings configure the connection between the host and the target. The Target panel is
shown in Figure 6.21.

Note:
The actual values for these settings depend on the configuration of your host, target, and Ether-
net.

Figure 6.21. Target panel

In the Target panel, use the drop-down menu to select a target that you have registered with TimeStorm.
If you have not yet registered a target, click Manage targets to open the Targets management utility.
Refer to Appendix E in Getting Started with TimeStorm for details about using this utility. Targets that
are registered with TimeStorm using this utility can be used with TimeStorm and any of its plug-ins.
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6.5.5 Test the Download Setup
The Download Files panel, displayed in Figure 6.22, shows the files to be downloaded and includes op-
tions for testing the connections that you have configured.

Figure 6.22. Download Files panel

In the Download Files panel, click the Add File button to select the debug-with-profile/tutorial

file.

Then, click the Test button to determine if the target setup that you have chosen is correctly configured.
If not, make the necessary changes in the Target panel.

6.5.6 Save the Configuration
When you finish changing settings, click the Apply button in the Launch Configurations panel. The
new launch configuration appears in the Configurations list, as shown in Figure 6.23.
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Figure 6.23. The new launch configuration

6.5.7 Run the Application
From the Configurations list, select the launch configuration named tutorial and click the Run button
at the bottom of the panel.

If all has gone well, running the program causes the phrase "Welcome to TimeStorm" to be printed to
the Console view.

If all has not gone well, refer to Chapter 5, Downloading and Running Applications from TimeStorm, to
find out how to access debugging tools.
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